Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An error may occur when tracking an outgoing email in the Microsoft Dynamics CRM for Outlook client: "An error occurred promoting this item to Microsoft "


View products that this article applies to.

Symptoms

When tracking an outgoing email in the Microsoft Dynamics CRM for Outlook client, the following error may occur:

"An error occurred promoting this item to Microsoft CRM. The Microsoft CRM Server could not be contacted or the user has insufficient permissions to perform this action"

A CRM client side trace will show the following:

"The access credentials that you have specified have insufficient delegate permissions to send the e-mail message. Contact your Microsoft Exchange administrator to grant the required Permissions."

↑ Back to the top


Cause

This error can be caused by the following:

1. The Outlook contact or suggested contact has missing properties such as the email address or SMTP properties

2. The "HidecontactfromExchangeaddresslists" functionality in Microsoft Exchange is being used for either the Sender or Recipient address in the email. Using this functionality removes all SMTP and email address information from a contact when it is synchronized to Outlook, which is used for the CRM for Outlook client to promote an email. Instead, it provides an Exchange DN value in the Display Name field.

By default, Microsoft Dynamics CRM selects the user that tracks the email to display as the Sender of the email in CRM if it cannot find an SMTP email address for the Sender on the original email in Outlook.

↑ Back to the top


Resolution

If the MAPI properties are damaged or missing, try forwarding the email to the user that originally received the email. Then, Set Regarding to the correct contact. In addition, these properties may be able to be recreated. Please contact Outlook support for additional information on this process.

If the Outlook contact or suggested contact is missing properties, add the missing information such as the email address.

If using the "Hide contact from Exchange address lists" functionality in Microsoft Exchange, this type of behavior is by design and expected within Microsoft Dynamics CRM, as this Exchange functionality removes the necessary information needed for CRM to find the original Sender of the email from Outlook. The emails can be tracked manually by using Set Regarding to track this to the correct contact.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2708761
Revision : 1
Created on : 1/7/2017
Published on : 5/5/2012
Exists online : False
Views : 225