Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to bill service calls in Contract Administration in Microsoft Dynamics GP: "Cannot insert the value NULL into column 'ACTCAL', table 'xxx.dbo.SVC00601' "


View products that this article applies to.

Symptoms

You receive the following error when you try to run the service call billing in Contract Administration for Microsoft Dynamics GP:

[Microsoft][SQL Native Client][SQL Server]Cannot insert the value NULL into column 'ACTCAL', table 'xxx.dbo.SVC00601', column does not allow nulls. UPDATE fails.

↑ Back to the top


Cause

This message is typically due to a record in the SVC00601 table (SVC_Contract_Line) that has a blank contract number.

↑ Back to the top


Resolution

Find the blank record and remove it from the SVC00601.

1. Make a full backup and have all users exit Microsoft Dynamics GP.
2. Run the following script in SQL Server Management Studio against the company database.

select * from SVC00600 where CONTNBR = ''
select * from SVC00601 where CONTNBR = ''

3. If you receive results from step 2, delete those records using this script.

delete SVC00600 where CONTNBR = ''
delete SVC00601 where CONTNBR = ''

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2707968
Revision : 1
Created on : 1/7/2017
Published on : 5/18/2012
Exists online : False
Views : 167