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The Lpq.exe tool crashes in Windows Vista SP2 or in Windows Server 2008 SP2


View products that this article applies to.

Symptoms

On a computer that is running Windows Vista or Windows Server 2008, when you use the Lpq.exe tool, the tool crashes.
For example, consider the following scenario in a network environment:
  • You enable the LPD Print Service and LPR Port Monitor features on a Windows Server 2008-based print server.
  • You share a printer as a network printer by using the LPR port.
  • You pause the printing on the printer, and then you print many documents to the printer.
  • You run the following command on a client computer that is running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2):
    Lpq.exe -S <ServerName> -P <SharedPrinterName>
In this scenario, the Lpq.exe tool crashes. Additionally, you receive a 1073740940 application error.

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Cause

This issue is caused by a heap corruption in the LPRPutMsg function.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTime
Lpq.exe6.0.6002.228427,68026-Apr-201213:51
Lpr.exe6.0.6002.228428,70426-Apr-201213:51
Lprhelp.dll6.0.6002.2284213,31226-Apr-201214:44
Lprmon.dll6.0.6002.2284220,99226-Apr-201214:44
Lprmonui.dll6.0.6002.2284211,77626-Apr-201214:44
Setuplpr.dll6.0.6002.228428,19226-Apr-201214:45
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTime
Lpq.exe6.0.6002.228428,19226-Apr-201214:44
Lpr.exe6.0.6002.2284210,75226-Apr-201214:44
Lprhelp.dll6.0.6002.2284217,40826-Apr-201215:26
Lprmon.dll6.0.6002.2284226,62426-Apr-201215:26
Lprmonui.dll6.0.6002.2284214,33626-Apr-201215:26
Setuplpr.dll6.0.6002.228429,72826-Apr-201215:29
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTime
Lpq.exe6.0.6002.2284213,82426-Apr-201213:42
Lpr.exe6.0.6002.2284218,94426-Apr-201213:42
Lprhelp.dll6.0.6002.2284243,00826-Apr-201214:12
Lprmon.dll6.0.6002.2284261,44026-Apr-201214:12
Lprmonui.dll6.0.6002.2284233,28026-Apr-201214:12
Setuplpr.dll6.0.6002.2284219,45626-Apr-201214:13

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the line printer remote (LPR) port monitor, visit the following Microsoft website:For more information about the print services role, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the same issue in Windows 7 or in Windows Server 2008 R2, click the following article number to view the article in the Microsoft Knowledge Base:
2701239 The Lpq.exe tool crashes in Windows 7 or in Windows Server 2008 R2

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_78fba8a2c4dbf0833f4b3228fe329b6a_31bf3856ad364e35_6.0.6002.22842_none_9fbcf5bcbf750fec.manifest
File versionNot applicable
File size711
Date (UTC)26-Apr-2012
Time (UTC)16:24
File nameX86_microsoft-windows-p..ting-lprportmonitor_31bf3856ad364e35_6.0.6002.22842_none_b64a8414543113eb.manifest
File versionNot applicable
File size19,125
Date (UTC)26-Apr-2012
Time (UTC)15:01
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_a7f460e00979ba93c2999b83496f32f0_31bf3856ad364e35_6.0.6002.22842_none_a0ea6e6fecfb380f.manifest
File versionNot applicable
File size715
Date (UTC)26-Apr-2012
Time (UTC)16:24
File nameAmd64_microsoft-windows-p..ting-lprportmonitor_31bf3856ad364e35_6.0.6002.22842_none_12691f980c8e8521.manifest
File versionNot applicable
File size19,459
Date (UTC)26-Apr-2012
Time (UTC)15:53
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_7886a34746add72f34c97b40c27683cf_31bf3856ad364e35_6.0.6002.22842_none_1b500efa40d259cd.manifest
File versionNot applicable
File size713
Date (UTC)26-Apr-2012
Time (UTC)16:24
File nameIa64_microsoft-windows-p..ting-lprportmonitor_31bf3856ad364e35_6.0.6002.22842_none_b64c280a542f1ce7.manifest
File versionNot applicable
File size19,447
Date (UTC)26-Apr-2012
Time (UTC)14:21

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

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Article Info
Article ID : 2705543
Revision : 2
Created on : 9/25/2018
Published on : 9/25/2018
Exists online : False
Views : 208