Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an unhandled exception when you develop and then run a Lync Server 2010, UCMA 3.0-based application


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You develop an application that creates one or more user endpoints by using Microsoft Lync Server 2010, Unified Communications Managed API 3.0 (UCMA 3.0).
  • One of the user endpoints uses a user account that is homed in a Microsoft Office Communications Server 2007 R2 environment.
  • The endpoint signs in, and you wait about 30 minutes.
In this scenario, the UCMA application encounters an unhandled NullReferenceException exception. Additionally, when you do not use an unhandled exception handler, the application crashes.

↑ Back to the top


Cause

This issue occurs because of a protocol change in Lync Server 2010 and in UCMA 3.0. This change causes compatibility issues between Lync Server 2010, UCMA 3.0, and Office Communications Server 2007 R2. Therefore, an unhandled exception occurs when in-band provisioning data is updated.

↑ Back to the top


Resolution

To resolve this issue, install the following cumulative update:
2701655 Description of the cumulative update for Lync Server 2010, Unified Communications Managed API 3.0 Runtime: June 2012

↑ Back to the top


Keywords: kbqfe, kbsurveynew, kbfix, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2703332
Revision : 1
Created on : 1/7/2017
Published on : 6/16/2012
Exists online : False
Views : 303