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The event log files become corrupted in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have an application that logs events in the�event logs.
  • You run the application on a computer that is running Windows 7 or Windows Server 2008 R2.
  • The application logs some large events through the TraceSource and EventLogTraceListener classes that are included with the Microsoft .NET Framework.
In this scenario, the event log files become corrupted. Additionally, the event logs no longer log events.

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Cause

This issue occurs because the events are too large to be logged within one chunk. In this situation, the event logs do not write the complete chunk to disk before the associated timer frees the buffer.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are important for maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.1.7600.212081,087,48805-May-201207:42x86
Wevtsvc.dll6.1.7601.219881,088,00005-May-201207:33x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.1.7600.212081,648,64005-May-201208:38x64
Wevtsvc.dll6.1.7601.219881,647,10405-May-201208:18x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.1.7600.212082,902,52805-May-201207:35IA-64
Wevtsvc.dll6.1.7601.219882,902,52805-May-201207:25IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about event logs, go to the following Microsoft TechNet website:For more information about the TraceSource and EventLogTraceListener classes, go to the following Microsoft Developer Network (MSDN) websites: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_1a91e4366a3e9403b97ac540d842b9ef_31bf3856ad364e35_6.1.7600.21208_none_788ab02ec6291ddc.manifest
File versionNot applicable
File size696
Date (UTC)05-May-2012
Time (UTC)13:29
PlatformNot applicable
File nameX86_6fe642c1630178d440b1f805c01dd160_31bf3856ad364e35_6.1.7601.21988_none_d6b74a34d2484051.manifest
File versionNot applicable
File size696
Date (UTC)05-May-2012
Time (UTC)13:29
PlatformNot applicable
File nameX86_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7600.21208_none_dd7db4b28d06f08f.manifest
File versionNot applicable
File size40,903
Date (UTC)05-May-2012
Time (UTC)08:52
PlatformNot applicable
File nameX86_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7601.21988_none_df0dba368a6e08c1.manifest
File versionNot applicable
File size40,903
Date (UTC)05-May-2012
Time (UTC)08:32
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_1f839a51a5f7386aaa75667d47736be9_31bf3856ad364e35_6.1.7600.21208_none_2405678643f465bb.manifest
File versionNot applicable
File size700
Date (UTC)05-May-2012
Time (UTC)13:29
PlatformNot applicable
File nameAmd64_65bcaa040603e0be1bcbe45c92a8ddb2_31bf3856ad364e35_6.1.7601.21988_none_e6645b12caa5f024.manifest
File versionNot applicable
File size700
Date (UTC)05-May-2012
Time (UTC)13:29
PlatformNot applicable
File nameAmd64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7600.21208_none_399c5036456461c5.manifest
File versionNot applicable
File size40,907
Date (UTC)05-May-2012
Time (UTC)09:42
PlatformNot applicable
File nameAmd64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7601.21988_none_3b2c55ba42cb79f7.manifest
File versionNot applicable
File size40,907
Date (UTC)05-May-2012
Time (UTC)09:27
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_4932daa638e2356f128a918ab545962a_31bf3856ad364e35_6.1.7601.21988_none_a7b46fdedeaa6991.manifest
File versionNot applicable
File size698
Date (UTC)05-May-2012
Time (UTC)13:29
PlatformNot applicable
File nameIa64_894d1ddec71d001975077a1ceee93c54_31bf3856ad364e35_6.1.7600.21208_none_dcd45e53cfe5e870.manifest
File versionNot applicable
File size698
Date (UTC)05-May-2012
Time (UTC)13:29
PlatformNot applicable
File nameIa64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7600.21208_none_dd7f58a88d04f98b.manifest
File versionNot applicable
File size40,905
Date (UTC)05-May-2012
Time (UTC)08:57
PlatformNot applicable
File nameIa64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7601.21988_none_df0f5e2c8a6c11bd.manifest
File versionNot applicable
File size40,905
Date (UTC)05-May-2012
Time (UTC)08:48
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2701799

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Article Info
Article ID : 2701799
Revision : 1
Created on : 6/12/2012
Published on : 6/12/2012
Exists online : False
Views : 378