Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Appointments continuously resynchronize in the Microsoft Dynamics CRM for Microsoft Office Outlook client or produce the error: "An unknown error occurred while synchronizing data to Outlook"


View products that this article applies to.

Symptoms

By default, appointment records created in the Microsoft Dynamics CRM web client automatically populate the organizer field as the creating user. However, the data in this field can be removed and is not considered required.

In the Microsoft Dynamics CRM 4.0 Outlook client, if the organizer field data is removed from an appointment, and then the record is synchronized, this may result in the object being repeatedly synchronized. If client tracing is enabled, the following log will be generated:

[2012-03-06 14:15:17.893] Process:OUTLOOK |Thread:0904 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | CCalItemHelper::HrMapiRecipientsToDynamicEntites File: c:\bt\13487\src\application\outlook\addin\calitemhelper.cpp Line: 1151
>hr = 0x8007000e
[2012-03-06 14:15:17.893] Process:OUTLOOK |Thread:0904 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | CCalItemHelper::HrAddRecipientsToCrmItem File: c:\bt\13487\src\application\outlook\addin\calitemhelper.cpp Line: 1894
>hr = 0x8007000e
[2012-03-06 14:15:17.893] Process:OUTLOOK |Thread:0904 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | CCalItemHelper::HrAddOtherPropertiesToCrmItem File: c:\bt\13487\src\application\outlook\addin\calitemhelper.cpp Line: 789
>hr = 0x8007000e

However, in the Microsoft Dynamics CRM 2011 Outlook client, this may produce the following error during synchronization:

"An unknown error occurred while synchronizing data to Outlook"

 CRM 2011 sample synchronization error for appointments with blank organizer

 

↑ Back to the top


Cause

The organizer field on the synchronized appointment record is blank.

↑ Back to the top


Resolution

Ensure that the organizer field is appropriately populated on the appointment records that are producing this behavior.

In addition, the following actions can be taken to help mitigate this issue for future occurences:
  1. Make the organizer field a required field on the appointment form.
  2. Create a workflow that fires on create and update of an appointment record to check if the organizer field is blank. If the field is blank, add the owner of the record as the appointment organizer.
  3. Open the appointment in Outlook and populate the organizer field, then synchronize. 
  4. Create a plugin that ensures that the organizer field is populated when an appointment is created or updated.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2700417
Revision : 1
Created on : 1/7/2017
Published on : 6/15/2012
Exists online : False
Views : 298