Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Memory leak in the Remote Registry service on a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you query performance counters on a remote computer by using an application on a computer that is running Windows 7 or Windows Server 2008 R2. In this situation, the memory usage of the Remote Registry service on the local computer increases until the available memory is exhausted.

Notes
  • The Remote Registry service runs in a Svchost.exe process. To identify this Svchost.exe process, open a command prompt, type the following command, and then press Enter:
    tasklist -svc
  • If you use Performance Monitor when this issue occurs, you notice that the memory used by the Svchost.exe process increases continuously.

↑ Back to the top


Cause

This issue occurs because mutex objects and query handles are not closed.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTime
Regsvc.dll6.1.7600.21182113,15206-Apr-201206:56
Regsvc.dll6.1.7601.21959113,66406-Apr-201207:41
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Regsvc.dll6.1.7600.21182160,76806-Apr-201207:44
Regsvc.dll6.1.7601.21959160,76806-Apr-201207:37
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Regsvc.dll6.1.7600.21182333,31206-Apr-201206:28
Regsvc.dll6.1.7601.21959333,31206-Apr-201206:27

↑ Back to the top


Workaround

To work around this issue, restart the Remote Registry service.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_0293a110ed4c0742210a3f2e5cd857b7_31bf3856ad364e35_6.1.7600.21182_none_43a30c9ed4ce022a.manifest
File versionNot applicable
File size710
Date (UTC)07-Apr-2012
Time (UTC)17:20
File nameX86_1e09586eb84d9c0139b8caa8266b4a5d_31bf3856ad364e35_6.1.7601.21959_none_66b681ee99bd11b3.manifest
File versionNot applicable
File size710
Date (UTC)07-Apr-2012
Time (UTC)17:20
File nameX86_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7600.21182_none_89c2db4ffdeb5c63.manifest
File versionNot applicable
File size8,057
Date (UTC)06-Apr-2012
Time (UTC)07:48
File nameX86_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7601.21959_none_8bd0d3e3faf2efc2.manifest
File versionNot applicable
File size8,057
Date (UTC)06-Apr-2012
Time (UTC)08:43
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_01e14ef91307d4ef30707b98cd051066_31bf3856ad364e35_6.1.7601.21959_none_463a074c58a1d146.manifest
File versionNot applicable
File size714
Date (UTC)07-Apr-2012
Time (UTC)17:20
File nameAmd64_e2ced674ab74aff8fc04995e5566ef8b_31bf3856ad364e35_6.1.7600.21182_none_3767e8569cd98796.manifest
File versionNot applicable
File size714
Date (UTC)07-Apr-2012
Time (UTC)17:20
File nameAmd64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7600.21182_none_e5e176d3b648cd99.manifest
File versionNot applicable
File size8,061
Date (UTC)06-Apr-2012
Time (UTC)08:50
File nameAmd64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7601.21959_none_e7ef6f67b35060f8.manifest
File versionNot applicable
File size8,061
Date (UTC)06-Apr-2012
Time (UTC)09:04
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_728f1fe4afba6642f5b766a20e7debcc_31bf3856ad364e35_6.1.7600.21182_none_24502cea90127186.manifest
File versionNot applicable
File size712
Date (UTC)07-Apr-2012
Time (UTC)17:20
File nameIa64_ec939150eb16064fe49d04d988dd23fb_31bf3856ad364e35_6.1.7601.21959_none_159897d7e57ab775.manifest
File versionNot applicable
File size712
Date (UTC)07-Apr-2012
Time (UTC)17:20
File nameIa64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7600.21182_none_89c47f45fde9655f.manifest
File versionNot applicable
File size8,059
Date (UTC)06-Apr-2012
Time (UTC)10:14
File nameIa64_microsoft-windows-remoteregistry-service_31bf3856ad364e35_6.1.7601.21959_none_8bd277d9faf0f8be.manifest
File versionNot applicable
File size8,059
Date (UTC)06-Apr-2012
Time (UTC)10:41

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2699780
Revision : 1
Created on : 1/7/2017
Published on : 5/9/2012
Exists online : False
Views : 225