Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Managed Folder Assistant does not process a mailbox that has external contacts in another tenant organization in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Microsoft Exchange Server 2010 Service Pack 1 (SP1) in hosting mode by using the /hosting switch.
  • You create two tenant organizations (organization 1 and organization 2) in the Exchange Server 2010 SP1 environment. 
  • Organization 1 contains a mail-enabled user (user A).
  • You create an external contact in organization 2 for user A.
  • You run the Start-ManagedFolderAssistant cmdlet so that the Managed Folder Assistant will process user A’s mailbox in organization 1.
In this scenario, the Managed Folder Assistant does not process the mailbox. Additionally, the following event is logged in the Application log:
Log Name: Application
Source: MSExchangeMailboxAssistants
Date: Date & Time
Event ID: 10021s
Task Category: Managed Folder Assistant
Level: Error
Keywords: Classic
User: N/A
Computer: Computer
Description:
The MRM Assistant will skip processing mailbox mailbox. Exception details: 'Microsoft.Exchange.Assistants.SkipException: Couldn't get user information for mailbox mailbox from the Active Directory.
at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserInformation..ctor(MailboxSession session)
at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserTagInformation..ctor(MailboxSession session, Dictionary`2 allAdTags)
at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ElcUserTagInformation..ctor(MailboxSession session)
at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.SysCleanupSubAssistant.BuildMailboxData(MailboxSession mailboxSession)
at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.SysCleanupSubAssistant.Invoke(MailboxSession mailboxSession, MailboxDataForTags& mailboxDataForTags)
at Microsoft.Exchange.MailboxAssistants.Assistants.ELC.ELCAssistant.<>c__DisplayClass6.<InvokeInternal>b__0()at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)'.

↑ Back to the top


Cause

This issue occurs because the Managed Folder Assistant uses a global scope incorrectly and does not use a unique identifier to open the mailbox. Therefore, two objects that have the same Simple Mail Transfer Protocol (SMTP) address are returned, and the Managed Folder Assistant does not process the mailbox.


↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the Start-ManagedFolderAssistant cmdlet, go to the following Microsoft website:For more information about multi-tenant Exchange deployments, go to the following Microsoft website:For more information about how to create a tenant organization, go to the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2698976
Revision : 1
Created on : 1/7/2017
Published on : 6/28/2012
Exists online : False
Views : 358