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"0x8000ffff" error message when you try to restore a Windows 7-based computer by using System Restore


View products that this article applies to.

Symptoms

When you try to restore a Windows 7-based computer by using System Restore in Windows Recovery Environment (WinRE), you receive the following error message:

System Restore did not complete successfully. Your computer's system files and settings were not changed.

Details:
An unspecified error occurred during System Restore. (0x8000ffff)

You can try System Restore again and choose a different restore point. If you continue to see this error, you can try an advanced recovery method. For more information, see What is Recovery?

Additionally, after you restart the computer, you receive the following message:

System Restore completed successfully. The system has been restored to datetime. Your documents have not been affected.

Note In this message, date time represents the actual date and time of the system restoration point.

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Cause

This problem occurs because certain files are not replaced correctly if a file conflict occurs during the restore process. Be aware that System Restore may have failed even though the "System Restore has completed successfully" message is displayed.


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Resolution

To resolve this problem, apply the hotfix package that is described in Microsoft Knowledge Base article 2709289 to the Windows Imaging Format (.wim) file in your WinRE environment. To do this, click the following link to view Microsoft Knowledge Base article 2709289, and then follow the instructions in the article:
2709289 System Restore tool does not work in Windows RE on a Windows 7-based computer

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Workaround

To work around this problem, use the Windows System Restore wizard. To do this, follow these steps:
  1. Click Start, and then type System Restore in the Start Search box.
  2. Right-click System Restore, and then click Run as administrator.
  3. In the System Restore dialog box, click Next.
  4. Select a restore point, and then click Next.
  5. In the "Confirm your restore point" window, click Finish.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

This problem does not affect user data, and it will not cause user data to be lost or corrupted.

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Keywords: kbexpertiseinter, kbprb, kbsurveynew, kb

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Article Info
Article ID : 2695585
Revision : 1
Created on : 1/7/2017
Published on : 7/13/2012
Exists online : False
Views : 142