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"Printer Installation Failed" error message when you try to install a printer driver from an IPP server website on a Windows 7 or Windows Server 2008 R2-based computer


View products that this article applies to.

Symptoms

Assume that you use Windows Internet Explorer to access an Internet Printing Protocol (IPP) server website on a Windows 7 or Windows Server 2008 R2-based computer. When you try to install a particular third-party color printer driver from the website, the installation fails. Additionally, you receive the following error message:
Printer Installation Failed
Not Empty

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Cause

This issue occurs because both the .webpnp file and the driver package contain the same .icm file. Therefore, when Internet Explorer starts the Wpnpinst.exe process, the process detects the conflict and then reports an error.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows 7 and Windows Server 2008 R2RTMGDR
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.1.7600.21180125,44004-Apr-20124:34x86
Inetppui.dll6.1.7600.1638518,94414-Jul-20091:15x86
Wpnpinst.exe6.1.7600.2118039,42404-Apr-20124:32x86
Inetpp.dll6.1.7601.21957126,46404-Apr-20124:20x86
Inetppui.dll6.1.7600.1638518,94414-Jul-20091:15x86
Wpnpinst.exe6.1.7601.2195739,42404-Apr-20124:18x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.1.7600.21180164,86404-Apr-20125:22x64
Inetppui.dll6.1.7600.1638522,52814-Jul-20091:41x64
Wpnpinst.exe6.1.7600.2118048,64004-Apr-20125:20x64
Inetpp.dll6.1.7601.21957166,40004-Apr-20125:19x64
Inetppui.dll6.1.7600.1638522,52814-Jul-20091:41x64
Wpnpinst.exe6.1.7601.2195748,64004-Apr-20125:17x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.1.7600.21180395,26404-Apr-20124:18IA-64
Inetppui.dll6.1.7600.1638551,71214-Jul-20091:46IA-64
Wpnpinst.exe6.1.7600.21180127,48804-Apr-20124:16IA-64
Inetpp.dll6.1.7601.21957398,84804-Apr-20124:12IA-64
Inetppui.dll6.1.7600.1638551,71214-Jul-20091:46IA-64
Wpnpinst.exe6.1.7601.21957127,48804-Apr-20124:09IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_996c1362b2841e3e11453caf8b732214_31bf3856ad364e35_6.1.7601.21957_none_de0a6167b8e8b6e2.manifest
File versionNot applicable
File size720
Date (UTC)04-Apr-2012
Time (UTC)9:24
PlatformNot applicable
File nameX86_bf73c734c24626c5bfcdc1b087b702e4_31bf3856ad364e35_6.1.7600.21180_none_810d8036ca3eb70d.manifest
File versionNot applicable
File size720
Date (UTC)04-Apr-2012
Time (UTC)9:24
PlatformNot applicable
File nameX86_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.21180_none_8b2d3ab042d912f6.manifest
File versionNot applicable
File size5,259
Date (UTC)04-Apr-2012
Time (UTC)9:29
PlatformNot applicable
File nameX86_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7601.21957_none_8d3b33443fe0a655.manifest
File versionNot applicable
File size5,259
Date (UTC)04-Apr-2012
Time (UTC)9:29
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_b1127768cd8f7a58cbf17613ee837d6e_31bf3856ad364e35_6.1.7600.21180_none_8b22346fa359c64d.manifest
File versionNot applicable
File size724
Date (UTC)04-Apr-2012
Time (UTC)9:24
PlatformNot applicable
File nameAmd64_b4a2cbbc0ce3e7c36226345d35533120_31bf3856ad364e35_6.1.7601.21957_none_ae945bfb17146b6e.manifest
File versionNot applicable
File size724
Date (UTC)04-Apr-2012
Time (UTC)9:24
PlatformNot applicable
File nameAmd64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.21180_none_e74bd633fb36842c.manifest
File versionNot applicable
File size5,263
Date (UTC)04-Apr-2012
Time (UTC)9:33
PlatformNot applicable
File nameAmd64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7601.21957_none_e959cec7f83e178b.manifest
File versionNot applicable
File size5,263
Date (UTC)04-Apr-2012
Time (UTC)9:33
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_6b9f4964bb2c9bfd14df962864b9f080_31bf3856ad364e35_6.1.7600.21180_none_95c2cece7e561f46.manifest
File versionNot applicable
File size722
Date (UTC)04-Apr-2012
Time (UTC)9:24
PlatformNot applicable
File nameIa64_8942b1f142efc7a90ee51410c84936f3_31bf3856ad364e35_6.1.7601.21957_none_32fee348df3c07f5.manifest
File versionNot applicable
File size722
Date (UTC)04-Apr-2012
Time (UTC)9:24
PlatformNot applicable
File nameIa64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.21180_none_8b2edea642d71bf2.manifest
File versionNot applicable
File size5,261
Date (UTC)04-Apr-2012
Time (UTC)9:25
PlatformNot applicable
File nameIa64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7601.21957_none_8d3cd73a3fdeaf51.manifest
File versionNot applicable
File size5,261
Date (UTC)04-Apr-2012
Time (UTC)9:25
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2695207
Revision : 1
Created on : 1/7/2017
Published on : 5/14/2012
Exists online : False
Views : 211