The System Center Advisor on-premises client version 1.1 and later versions are compatible with the Microsoft System Center 2012 Operations Manager suite. Version 1.1 and later versions add new monitoring workloads and fix several important issues.
This update introduces the following new features:
- Support for System Center 2012 Operations Manager
You can use System Center Advisor on the same computer on which you are running the System Center 2012 version of the Operations Manager agent. - Analysis for Microsoft SQL Server 2012
- Analysis for Microsoft SharePoint 2010 and later versions
- Analysis for Microsoft Exchange Server 2010 and later versions
- Additional Windows PowerShell cmdlets to support running System Center Advisor in environments that require action accounts or RunAs accounts.
For more information about System Center Advisor, go to the following Microsoft website:
This update resolves the following issues.
Issue 1
Symptom
The System Center Advisor agent stops collecting and uploading data for the monitored server. When this issue occurs, the System Center Operations Manager HealthService service stops responding and consumes lots of memory. Memory usage may exceed 1 gigabyte (GB). In this case, you may be unable to stop the HealthService service.
Cause
This issue occurs because a timer that checks for action account credentials is recycled incorrectly.
Issue 2
Symptom
The System Center Operations Manager HealthService service shuts down itself after the Advisor Management Pack Update process is executed in certain scenarios.
Issue 3
Symptom
The System Center Operations Manager HealthService service is stopped unexpectedly after Microsoft Update (MU) for System Center Advisor critical update version 1.0.2021.0 is installed.
Issue 4
Symptom
The System Center Advisor configuration process does not register the System Center Advisor agent to the System Center Advisor cloud server.
Cause
This issue occurs because the Machine.xml file is locked.
Issue 5
Symptom
You cannot uninstall the System Center Advisor agent.
Cause
This issue occurs because the PublicKeyToken request queues up. Therefore, the agent does not stop the System Center Operations Manager HealthService service successfully.
Issue 6
Symptom
The removal of System Center Advisor Gateway does not clean up incoming firewall rules and URLs that are reserved by System Center Advisor.
Issue 7
Symptom
System Center Advisor Gateway does not report its version until the Gateway service is restarted.