Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Profile Error 4 Occurs When Creating New User Profiles in Windows 95


View products that this article applies to.

This article was previously published under Q269100
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you use Microsoft Windows 95 and Windows 95 Original Equipment Manufacturer (OEM) Service Release 2 (OSR2) with Microsoft Internet Explorer installed, and you log on to the computer for the first time, you may receive the following error message:
An error occurred while creating a file in C:\Windows\Profiles\username\Cookies\*.*
Profile Error 4: The file cannot be created. The volume may not support long file names. Some of your profile settings may not be available.
Do you want to see this message in the future?

↑ Back to the top


Cause

The error message can occur when there is a "\" at the end of the data value for the string value names Cache, Cookies, Favorites, History or Personal under the following registry key:
HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders.

↑ Back to the top


Resolution

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this behavior and to prevent the error message from recurring, follow these steps:
1.On Start menu, click Run.
2.In the Open box, type regedit.
3.Expand the HKEY_USERS key down to the following subkey:
HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
4.Remove any trailing backslashes (\) from the paths for Cache, Cookies, Favorites, History, and Personal keys.
5.Close Registry Editor.

↑ Back to the top


More information

When you change the registry to prevent profile error 4 messages, you may receive a profile error 2 message.

For additional information about profile error 2 messages, click the article number below to view the article in the Microsoft Knowledge Base:
233339 Profile Error Number 2 When You Log On to Your Computer

↑ Back to the top


Keywords: KB269100, kbprb, kbenv, kberrmsg

↑ Back to the top

Article Info
Article ID : 269100
Revision : 4
Created on : 1/14/2006
Published on : 1/14/2006
Exists online : False
Views : 301