Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Chat feature missing in Outlook Web App for Exchange 2010


View products that this article applies to.

Symptoms

Consider the following scenario. The Exchange Server 2010 Client Access Server (CAS) has three or more web sites for Outlook Web App (OWA). Users report that the Chat feature in Outlook Web App (OWA) is not present and no Instant Messaging contacts are displayed.

The event ID shown here is logged in the Application Events on the CAS.

Source: MSExchangeOWA
Event ID: 87
Level: Error
Task Category: InstantMessage
Details: An exception was thrown while attempting to load the IM provider .dll file.

File: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\OWA\bin\Microsoft.Rtc.UCWeb.dll
Failed to listen on any address and port supplied.

This problem can affect different web sites after you perform an IISRESET or restart the IIS Admin service.

↑ Back to the top


Cause

When you configure Office Communicator Server (OCS) for instant messaging in OWA, the OCS client library requires a port for incoming connections from the OCS servers. OWA supports only a limited number of ports when initializing the OCS client library.

↑ Back to the top


Resolution

To resolve this issue, reduce the number of OWA sites on the CAS server to�two or less.

↑ Back to the top


More information

For more information about how to configure Office Communications Server and instant messaging for OWA, see the following topics from Microsoft TechNet online:

Microsoft Office Communications Server 2007 R2 Web Service Provider

Enable Exchange 2010 SP1 Outlook Web App and IM Integration


↑ Back to the top


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

↑ Back to the top


Keywords: KB2688771, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2688771
Revision : 4
Created on : 3/13/2012
Published on : 3/13/2012
Exists online : False
Views : 333