Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"The combination of user ID and password entered is invalid" error message when you use a valid Windows logon account to log on to Microsoft Dynamics NAV 2009


View products that this article applies to.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

↑ Back to the top


Symptoms

Assume that a Windows logon account belongs to 892 or more Windows security groups. When you use the Windows logon account to log on to Microsoft Dynamics NAV 2009 R2 and Microsoft Dynamics NAV 2009 Service Pack 1 (SP1), you receive the following error message:
The combination of user ID and password entered is invalid. Try again.
When this problem occurs, you cannot connect the Microsoft Dynamics NAV client to the Microsoft SQL Server database for Microsoft Dynamics NAV by using this Windows logon account.

This problem only occurs when you use a 64-bit version of Microsoft SQL Server with Microsoft Dynamics NAV 2009.

↑ Back to the top


Cause

This problem occurs because the Microsoft Dynamics NAV client runs the xp_ndo_enumusersids extended stored procedure in Microsoft SQL Server at the logon time and this returns a Windows error message because of an insufficient buffer size.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website: You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.


If you click Cancel, the download process stops.


How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Xp_ndo_x64.dll6.0.33284.0199,51213-Mar-201206:34x64

Prerequisites

You must have one of the following products installed to apply this hotfix:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1
Special note for Microsoft Dynamics NAV 2009 Service Pack 1
Before you apply this hotfix to a Microsoft Dynamics NAV 2009 Service Pack 1 installation, make sure that the current Microsoft Dynamics NAV 2009 SP1 installation has build number 32074 or a later build number. For more information, visit one of the following Microsoft websites, depending on whether you are a partner or a customer:
Partner
Combined Hotfix Release for Microsoft Dynamics NAV 2009 SP1 and Microsoft Dynamics NAV 2009 R2

Customer
Combined Hotfix Release for Microsoft Dynamics NAV 2009 SP1 and Microsoft Dynamics NAV 2009 R2

If the build number of the current Microsoft Dynamics NAV 2009 Service Pack 1 installation is less than 32074, you must perform one of the following steps before you can install this hotfix:
  • Install hotfix 2496107. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    2496107 Platform hotfix resource files for Microsoft Dynamics NAV 2009 Service Pack 1
  • Perform a solution upgrade to Microsoft Dynamics NAV 2009 R2. For more information about how to perform a solution upgrade from Microsoft Dynamics NAV 2009 Service Pack 1 to Microsoft Dynamics NAV 2009 R2, visit the following Microsoft website:
    Install and Upgrade Instructions for Microsoft Dynamics NAV 2009 R2
For information about how to find the build number in Microsoft Dynamics NAV, visit one of the following Microsoft websites, depending on whether you are a partner or a customer:
Partner
How to Find the Build Number in Microsoft Dynamics NAV

Customer
How to Find the Build Number in Microsoft Dynamics NAV

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

↑ Back to the top


Keywords: kbeagreements, kbnoloc, kbsurveynew, kbexpertiseinter, kbexpertisebeginner, kbexpertiseadvanced, kbautohotfix, kbmbsmigrate, kbhotfixserver, kb, kbmbspartner, kbqfe, kbmbsquickpub

↑ Back to the top

Article Info
Article ID : 2688689
Revision : 3
Created on : 1/31/2017
Published on : 1/31/2017
Exists online : False
Views : 177