Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"File not found" error message when you make changes to a file on a network share from a computer that is running Window 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a network share that is hosted on a remote file server that uses the Server Message Block Version 2 (SMB2) protocol.�
  • You�use an application to create, change, and delete files on the network share from a computer that is running Window 7 or Windows Server 2008 R2.�
  • When the file server is running under a heavy load, you open a file on the network share, wait a long time, and then try to make changes to the file. For example, you wait more than 40 minutes and then try to change the file.�
In this scenario, you receive the following error message:
File not found

↑ Back to the top


Cause

This issue occurs because of a race condition in the Redirected Drive Buffering Subsystem (Rdbss.sys) driver when many files are opened, deleted, and closed continually.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.1.7600.21166241,15209-Mar-201212:03x86
Rdbss.sys6.1.7601.21939241,66409-Mar-201211:48x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.1.7600.21166308,73609-Mar-201212:24x64
Rdbss.sys6.1.7601.21939309,24809-Mar-201212:15x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.1.7600.21166720,38409-Mar-201211:44IA-64
Rdbss.sys6.1.7601.21939721,40809-Mar-201211:40IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_0c4e7666a663df1cd264b1546b5c105c_31bf3856ad364e35_6.1.7601.21939_none_783339257aa7d144.manifest
File versionNot applicable
File size693
Date (UTC)09-Mar-2012
Time (UTC)21:06
PlatformNot applicable
File nameX86_e076f52cc22481d7def5f9c0347dfa32_31bf3856ad364e35_6.1.7600.21166_none_f65cd1ba3fff145c.manifest
File versionNot applicable
File size693
Date (UTC)09-Mar-2012
Time (UTC)21:06
PlatformNot applicable
File nameX86_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7600.21166_none_5a4b4e62dbc9a870.manifest
File versionNot applicable
File size21,803
Date (UTC)09-Mar-2012
Time (UTC)14:47
PlatformNot applicable
File nameX86_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7601.21939_none_5c5545ced8d4d673.manifest
File versionNot applicable
File size21,803
Date (UTC)09-Mar-2012
Time (UTC)14:28
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_663234267d308d22f37f5664c2ebb71f_31bf3856ad364e35_6.1.7601.21939_none_457f8c1bdcdd9771.manifest
File versionNot applicable
File size697
Date (UTC)09-Mar-2012
Time (UTC)21:06
PlatformNot applicable
File nameAmd64_905001ae36fa2c69409133dca77f2cc6_31bf3856ad364e35_6.1.7600.21166_none_af0d657566a1d228.manifest
File versionNot applicable
File size697
Date (UTC)09-Mar-2012
Time (UTC)21:06
PlatformNot applicable
File nameAmd64_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7600.21166_none_b669e9e6942719a6.manifest
File versionNot applicable
File size21,809
Date (UTC)09-Mar-2012
Time (UTC)15:43
PlatformNot applicable
File nameAmd64_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7601.21939_none_b873e152913247a9.manifest
File versionNot applicable
File size21,809
Date (UTC)09-Mar-2012
Time (UTC)16:09
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_15619b8a7d3b302dc9b6dff93b952049_31bf3856ad364e35_6.1.7601.21939_none_44f042cf7c0c48bf.manifest
File versionNot applicable
File size695
Date (UTC)09-Mar-2012
Time (UTC)21:06
PlatformNot applicable
File nameIa64_d3a808a0b483c41b7cf28914edfe340d_31bf3856ad364e35_6.1.7600.21166_none_f7fecc38ac18e87c.manifest
File versionNot applicable
File size695
Date (UTC)09-Mar-2012
Time (UTC)21:06
PlatformNot applicable
File nameIa64_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7600.21166_none_5a4cf258dbc7b16c.manifest
File versionNot applicable
File size21,806
Date (UTC)09-Mar-2012
Time (UTC)15:44
PlatformNot applicable
File nameIa64_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7601.21939_none_5c56e9c4d8d2df6f.manifest
File versionNot applicable
File size21,806
Date (UTC)09-Mar-2012
Time (UTC)15:21
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2687753

↑ Back to the top

Article Info
Article ID : 2687753
Revision : 3
Created on : 5/4/2012
Published on : 5/4/2012
Exists online : False
Views : 268