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A volume cannot be locked when there are approximately 1500 quota settings on the volume in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario: 
  • You have approximately 1500 separate quota settings on a volume on a computer that is running Windows Server 2003.
  • You use an application that uses the FSCTL_LOCK_VOLUME control code to lock the volume in order to prevent it from being accessed by other processes on the computer.
In this scenario, the application cannot lock the volume.

Notes
  • This issue typically occurs when the software has to lock the volume with exclusive access. For example, the issue can occur when you use NEC CLUSTERPRO (EXPRESSCLUSTER) because it tries to lock the volume to prevent from being accessed by other processes.
  • NEC CLUSTERPRO (EXPRESSCLUSTER) is a software application for cluster environments. It controls access to the volumes which are shared or mirrored between cluster servers.

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Cause

This issue occurs because the quota metadata file (Quota.md) becomes fragmented when there are too many quota settings on a volume. However, this behavior is not checked by Quota.sys.

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Resolution

Hotfix information

To resolve this issue, install the following hotfix on the affected computer that is running Windows Server 2003.

Hotfix information

Mainstream support for this product ended on July 13, 2010. Please review the Microsoft Support Lifecycle policy.

Extended Support

The Extended Support phase follows Mainstream Support for Business and Developer products.
At the supported service pack level, Extended Support includes the following:
  • Paid support
  • Security update support at no additional cost
Please note:
  • Non-security–related hotfix support requires the purchase of a separate Extended Hotfix Support Agreement (per-fix fees also apply).
  • Microsoft will not accept requests for warranty support, design changes, or new features during the Extended Support phase.
  • Extended Support is not available for Consumer, Hardware, or Multimedia products.
  • You may have to enroll in a maintenance program in order to receive these benefits for certain products.

Prerequisites

To apply this hotfix, your must be running Windows Server 2003 Service Pack 2 (SP2).For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Registry information

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.497289,60014-Mar-201212:39x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.4972133,12015-Mar-201206:34x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Quota.sys5.2.3790.4972281,08815-Mar-201206:35IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, kbautohotfix, kb

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Article Info
Article ID : 2684613
Revision : 1
Created on : 1/7/2017
Published on : 5/11/2012
Exists online : False
Views : 332