Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A volume is not locked or unmounted when there are approximately 1,500 quota settings on the volume in Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have approximately 1,500 separate quota settings on a volume on a computer that is running Windows Server 2008.
  • You run an application that performs one of the following actions:
    • The application uses the FSCTL_LOCK_VOLUME control code to lock the volume in order to prevent it from being accessed by other processes.
    • The application uses the FSCTL_DISMOUNT_VOLUME control code to unmount the volume.
In this scenario, the application does not lock or unmount the volume.

Note This issue typically occurs when the application locks the volume with exclusive access. For example, the issue can occur when you use NEC ExpressCluster, because this application tries to lock the volume to prevent other processes from accessing the volume.

↑ Back to the top


Cause

This issue occurs because the quota metadata file (Quota.md) becomes fragmented when there are too many quota settings on a volume. However, Quota.sys does not check this behavior.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 Service Pack 2 (SP2). For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Quota.sys6.0.6002.22816133,50414-Mar-201217:21x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Quota.sys6.0.6002.22816160,64014-Mar-201217:25x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameX86_ce329f1cf8cbf6b7234a64bc0de15016_31bf3856ad364e35_6.0.6002.22816_none_196835ea239ec3ed.manifest
File versionNot applicable
File size704
Date (UTC)14-Mar-2012
Time (UTC)17:31
PlatformNot applicable
File nameX86_microsoft-windows-fsrm-quotadriver_31bf3856ad364e35_6.0.6002.22816_none_e9d43d0a90ff820a.manifest
File versionNot applicable
File size11,233
Date (UTC)14-Mar-2012
Time (UTC)17:31
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_b14099c57a669a292ee64e6498ddad07_31bf3856ad364e35_6.0.6002.22816_none_c690832cdad462da.manifest
File versionNot applicable
File size708
Date (UTC)14-Mar-2012
Time (UTC)17:31
PlatformNot applicable
File nameAmd64_microsoft-windows-fsrm-quotadriver_31bf3856ad364e35_6.0.6002.22816_none_45f2d88e495cf340.manifest
File versionNot applicable
File size11,241
Date (UTC)14-Mar-2012
Time (UTC)17:31
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2684607
Revision : 1
Created on : 1/7/2017
Published on : 5/9/2012
Exists online : False
Views : 201