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"Failure in initializing the telnet session" error message when you try to log on to a Telnet server that is running Windows Server 2008 R2


View products that this article applies to.

Symptoms

When you try to log on to a Telnet server that is running Windows Server 2008 R2, you receive the following error message:
Failure in initializing the telnet session. Shell process may not have been launched.
Telnet Server has closed the connection.

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Cause

This issue occurs because of a behavior in the Seclogon.dll file on the Telnet server. If the environment variables contain more than 5,120 characters, the Seclogon.dll file returns an error to the CreateProcessWithTokenW function.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Seclogon.dll6.1.7600.2116330,72006-Mar-201206:41x64
Seclogon.dll6.1.7601.2193630,72006-Mar-201206:23x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Seclogon.dll6.1.7600.2116365,02406-Mar-201205:23IA-64
Seclogon.dll6.1.7601.2193665,02406-Mar-201205:21IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_57021c4078bff1422f05717467103775_31bf3856ad364e35_6.1.7600.21163_none_60fe11f0e60e5d26.manifest
File versionNot applicable
File size713
Date (UTC)06-Mar-2012
Time (UTC)14:54
PlatformNot applicable
File nameAmd64_845342d58d5c6a5bff7b98048e7dff37_31bf3856ad364e35_6.1.7601.21936_none_e457758b7ae360f8.manifest
File versionNot applicable
File size713
Date (UTC)06-Mar-2012
Time (UTC)14:54
PlatformNot applicable
File nameAmd64_microsoft-windows-secondarylogonservice_31bf3856ad364e35_6.1.7600.21163_none_48f67067ce5724d9.manifest
File versionNot applicable
File size4,810
Date (UTC)06-Mar-2012
Time (UTC)07:34
PlatformNot applicable
File nameAmd64_microsoft-windows-secondarylogonservice_31bf3856ad364e35_6.1.7601.21936_none_4b0067d3cb6252dc.manifest
File versionNot applicable
File size4,810
Date (UTC)06-Mar-2012
Time (UTC)07:12
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_42caedcf131d60e9f7c21879ba4295d1_31bf3856ad364e35_6.1.7601.21936_none_c792edf585a014a5.manifest
File versionNot applicable
File size711
Date (UTC)06-Mar-2012
Time (UTC)14:54
PlatformNot applicable
File nameIa64_63544ed07aa6686010bc201179e203fb_31bf3856ad364e35_6.1.7600.21163_none_aa90ce2f3e07f1a2.manifest
File versionNot applicable
File size711
Date (UTC)06-Mar-2012
Time (UTC)14:54
PlatformNot applicable
File nameIa64_microsoft-windows-secondarylogonservice_31bf3856ad364e35_6.1.7600.21163_none_ecd978da15f7bc9f.manifest
File versionNot applicable
File size4,808
Date (UTC)06-Mar-2012
Time (UTC)06:55
PlatformNot applicable
File nameIa64_microsoft-windows-secondarylogonservice_31bf3856ad364e35_6.1.7601.21936_none_eee370461302eaa2.manifest
File versionNot applicable
File size4,808
Date (UTC)06-Mar-2012
Time (UTC)06:40
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2683484

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Article Info
Article ID : 2683484
Revision : 1
Created on : 4/11/2012
Published on : 4/11/2012
Exists online : False
Views : 382