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XADM: Mailbox Manager May Access Violate Cleaning a Container with a Space in the Directory Name


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This article was previously published under Q268105

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Symptoms

If you use Mailbox Manager to clean a container with a hidden mailbox that has a space at the end of the directory name, Mailbox Manager may Access Violate. The DrWatson.log contains the following stack, if symbols are properly installed:
FramePtr  RetAddr   Param1   Param2   Param3   Function Name<BR/>

0162eb40  7801299d  00090004 00411130 0162f554 MSVCRT!__ascii_stricmp+0x17
0162eb54  7801296e  00090004 00411130 00402066 MSVCRT!_stricmp+0x2c
0162eb60  00402066  00090004 00411130 77e88778 MSVCRT!_strcmpi+0xd
0162f444  00406824  00851160 00414348 00850fd0 MBCLEAN!hrWalkUsersInContainer+0x1a6
0162f488  0040629d  00000000 00000000 00850fd0 MBCLEAN!ProcessOneContainer+0x474
0162f4f8  00405be6  00851160 0162f554 00850fd0 MBCLEAN!ProcessContainer+0xcd
0162fa20  004096bc  0162fa58 77f87e6c 0162fd70 MBCLEAN!StartMailboxCleanup+0x566(...)
0162fa44  77f9fb67  0162fda8 d490dba8 01bfe1f4 MBCLEAN!TimerAPCProc+0x25c
0162fa58  00000000  00000000 00000000 00000000 NTDLL!KiUserApcDispatcher+0x7
					

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Cause

This issue can occur because Mailbox Manager builds a list of mailboxes to send to the directory to be resolved. This resolution process strips the trailing spaces so the names can be resolved against the directory by using ambiguous name resolution, which causes the name lookup to fail and not populate the list with the required Messaging Application Programming Interface (MAPI) properties. When the directory returns this list to Mailbox Manager, Mailbox Manager does not check the list to determine whether all of the name lookups were successful. When Mailbox Manager attempts to gain access to an item in the list that was not successfully resolved, Mailbox Manager stops responding.

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Resolution

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014� XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5 Service Pack 3. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

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Keywords: KB268105, kbqfe, kbfix, kbexchange550sp4fix, kbexchange550presp4fix, kbbug

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Article Info
Article ID : 268105
Revision : 4
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 397