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MMSSPP does not maintain the content of the original Exchange mailbox after the account for a user is re-created in Office 365 dedicated


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Symptoms

In Microsoft Office 365 dedicated, Microsoft Managed Services Service Provisioning Provider (MMSSPP) does not maintain the content of the original Microsoft Exchange mailbox. This behavior occurs when one or more of the following conditions are true:
  • The account for a user is moved between domains or forests, and the objectGUID of the account changes.
  • The account for a user is re-created after the account is accidentally deleted.
  • The account for a user is re-created because of the user's status change.

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Cause

MMSSPP associates each user account by its objectGUID. Assume that a new Active Directory Domain Services (AD DS) account is created for a user after a domain or a forest is moved, or the account is accidentally deleted. In this case, the connection between the original user account and its objectGUID is broken.

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Resolution

To resolve this issue, use one of the following methods, as appropriate for your situation.

Domain moves

If an account must be moved between domains, use a process that keeps the objectGUID of the account. To do this, use migration tools such as Active Directory Migration Tool (ADMT) in move mode instead of in clone mode. For more information about how to use ADMT to migrate and restructure AD DS domains, visit the following Microsoft website:

For MMSSPP 11.1 or a later version: Forest moves, accidental deletions, or employee status changes

Use the Automatic Service Reconnection (ASR) feature of MMSSPP 11.1 or a later version if an account must be moved between forests or if the account is accidentally deleted. This feature indicates the objectGUID of the original source AD DS account for the new account. The original mailbox can be connected to the new account without any manual intervention.

For more information about the ASR feature for MMSSPP 11.1 or a later version, see the following Microsoft article:

For MMSSPP 10.3 or an earlier version: Forest moves, accidental deletions, or employee status changes

Microsoft must manually restore the content of the old mailbox to a newly provisioned mailbox. Make sure that the original AD DS account is deprovisioned, and then escalate the case to Microsoft. To escalate the case, please use the Exchange Online topic and the PST capture, transfer sub-topic when you submit a support incident online to Microsoft Online Services Support, or contact Microsoft Online Services Support by telephone .

Note Do not escalate issues to Microsoft if there are two active accounts and mailboxes. By default, disconnected mailboxes are purged from mailbox databases within 30 days. To avoid content loss that occurs after a 30-day disconnection, contact Microsoft Online Services Support by online submission or by telephone immediately.

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Keywords: kb, vkbportal250, vkbportal226

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Article Info
Article ID : 2679244
Revision : 2
Created on : 11/22/2019
Published on : 11/22/2019
Exists online : False
Views : 328