Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Validation fails on the EDI send pipeline when you process EDI messages that contain leading and trailing zeros and spaces in BizTalk Server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use Microsoft BizTalk Server 2010 or BizTalk Server 2009 to process inbound batched EDI messages.
  • You create a BizTalk party, and then you create an agreement.
  • On the Party A->Party B one-way agreement tab, you select one of the following options for the Inbound batch processing option setting in the Interchange Settings section:
    • Preserve Interchange - suspend Interchange on Error
    • Preserve Interchange - suspend Transaction Sets on Error
  • You select the Allow leading and trailing zeroes and spaces validation setting option in the Transaction Set Settings section.
  • You receive a message that contains leading and trailing zeros and spaces. For example, the message contains a decimal value.
In this scenario, the message passes validation on the EDI receive pipeline. However, the message fails validation on the EDI send pipeline. When this issue occurs, you may receive error messages that resemble the following:
Invalid character in data element
Leading or trailing space found

↑ Back to the top


Cause

This issue occurs because the EDI send pipeline is hard-coded not to allow leading and trailing zeros and spaces. Therefore, the EDI send pipeline ignores the validation setting that was specified for the agreement.

↑ Back to the top


Resolution

After you apply this hotfix, leading and trailing zeros and spaces are allowed on the EDI send pipeline for Batch In/Batch Out (BIBO) scenarios. Additionally, EDI data validation continues to work on the EDI send pipeline.

Cumulative update information

This issue was first fixed in the following cumulative update of BizTalk Server:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about how to configure local host settings, go to the following MSDN website: For more information about how to configure validation, go to the following MSDN website: For information about the service packs and cumulative update list for BizTalk Server, see Service pack and cumulative update list for BizTalk Server .
For more information about BizTalk hotfixes and service packs support, see Information about BizTalk hotfixes and service pack support .

↑ Back to the top


Keywords: kb, kbqfe, kbfix, kbexpertiseadvanced, kbsurveynew, kbbiztalk2010presp1fix, kbbts

↑ Back to the top

Article Info
Article ID : 2678762
Revision : 1
Created on : 1/7/2017
Published on : 10/10/2015
Exists online : False
Views : 536