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Error in Business Portal in Microsoft Dynamics Business GP: You do not have a user record in Personal Data Keeper


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Symptom

When you try to access the Project Center page in Business Portal in Microsoft Dynamics GP, you receive the following error message:

You do not have a user record in Personal Data Keeper. Contact your Microsoft Dynamics GP administrator for assistance
 

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Cause

This issue has a few different causes:

  • An incorrect employee is linked to the Personal Data Keeper (PDK) user.
  • An incorrect employee is linked to the Business Portal user.
  • The company ID has been changed in the PDK40001 after a recent upgrade, service pack or creation of a Test database.

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Resolution

1. To verify that the correct employee ID is linked to the PDK user log into Personal Data Keeper as 'sa.' On the Setup tab, click System, and then click User. In the PDK User Setup window, enter the User ID and company for the user receiving the error. Verify the value in the Employee ID field is correct. If it is incorrect, delete the PDK user, and create it again using the correct employee ID.

2. To verify that the correct employee ID is linked to the Business Portal user make note of the Employee ID found in Resolution 1. Then follow these steps:

a. Log into Business Portal (BP) with a user who as BP Administrator rights.

b. From the BP home page click Site Actions, then select Site Settings.

Note If you are using BP 5.1, then to access the Advanced Roles section go to Site Settings for the top-level Business Portal web site, and then click Business Portal Administration.

c. Under the Business Portal Administration section click Users.
d. In the User List find the user who is experiencing the problem and click on the user.
e. In the User Properties section click the Roles tab.
f. In the listing of Roles find the line that reads Employee -- Employee ID -- 'your company'.
g. Does the value in the Employee ID exactly match what was seen in Resolution 1?  It needs to.
h. If not, click Modify to open the Modify Portal and Advanced Roles window.
i. In the lower section where it says Role/Company use the drop-down to find "Employee/your company"
j. Once the employees populate the scrolling window, select the employee ID that was identified in Resolution 1.
k. Click OK and have the BP user try their timesheet again.

3. Verify the CMPNYNAM field in the PDK40001 is the correct CMPANYID. The CMPANYID and CMPNYNAM should appear the same in the PDK40001 as they do in the SY01500.  

Please enter the Company Name in place of XXXXX.  


select CMPANYID, CMPNYNAM, * from PDK40001 where CMPNYNAM = 'XXXXX'


select CMPANYID, CMPNYNAM, * from SY01500 where CMPNYNAM = 'XXXXX'


If these do not match, then change the CMPANYID in the PDK40001 to the correct ID using a SQL query tool. 

Note Create a restorable backup prior to running any update statements against the database.

The following is an example of an update statement that could be used:  


update PDK40001 set CMPANYID = 'YYYYY' where CMPNYNAM = 'XXXXX'


Note enter the Company Name in place of XXXXX and the Company ID from the SY01500 for YYYYY.

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Keywords: kbmbspartner, kbmbsmigrate, kb

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Article Info
Article ID : 2676909
Revision : 1
Created on : 1/7/2017
Published on : 5/17/2012
Exists online : False
Views : 233