Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error: �Explorer.exe - Unable To Locate Component This application has failed to start because iertutil.dll was not found"


View products that this article applies to.

Symptoms

When starting a Windows XP-based computer after installing Internet Explorer 8, you may see the following error message:
Explorer.EXE - Unable To Locate Component

This application has failed to start because iertutil.dll was not found. Re-installing the application may fix this problem
Note:�After clicking OK to the error message, the message box will close and you see an empty desktop without icons or a Taskbar.�The Resolution steps will work while on the blank desktop.

↑ Back to the top


Cause

This issue can occur if the file iertutil.dll is missing from the \Windows\system32 folder.

↑ Back to the top


Resolution

To resolve this issue, you should copy the file iertutil.dll from the \dllcache folder to the \system32�folder. Once the file has been copied, Internet Explorer 8 will complete the installation. To do this, follow the steps in the methods below starting with method 1, if method 1 does not resolve the issue, continue to method 2:

Method 1: Copy the missing file to the system32 folder

  1. With the error message displayed, press Ctrl + Alt + Delete�together on your keyboard to start the�Task Manager
  2. In�the Task Manager, click New Task..., type CMD�and�click OK
  3. Type�the following text�in the�CMD.exe window and�press the�Enter key on your keyboard

    Copy C:\Windows\system32\dllcache\iertutil.dll c:\windows\system32

    Note: You should see a message saying "1 file copied" (If you see a message saying "File not found" continue to method 2).
  4. Restart the PC

    Note:�Internet Explorer 8 installation will complete. Do not turn off your computer untill the installation is complete. If prompted, restart the PC again

Method 2: Uninstall Internet Explorer 8 and then reinstall using the full download package

  1. With the error message displayed, press Ctrl + Alt + Delete�together on your keyboard to start the�Task Manager
  2. In the Task Manager, click New Task...,�type�the following text and click�OK

    %windir%\ie8\spuninst\spuninst.exe

    The uninstall wizard for Internet Explorer 8 will start, just follow steps in the wizard

    Note: You may see instances of the error message, just click OK�and allow the uninstall to continue.

    Once completed, the PC will restart. Internet Explorer will revert to a previous version
  3. Click the�link below to download and install the standalone version of the Internet Explorer 8 installation package

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=43



↑ Back to the top


Keywords: KB2676742

↑ Back to the top

Article Info
Article ID : 2676742
Revision : 1
Created on : 2/15/2012
Published on : 2/15/2012
Exists online : False
Views : 380