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Long startup or logon time when no domain controllers are available on a Windows 7-based or Windows Server 2008 R2-based domain member computer


View products that this article applies to.

Symptoms

Assume that you have a computer that is running Windows 7 or Windows Server 2008 R2 in a Windows Server 2008 R2-based domain environment. When there are no domain controllers available, the computer's startup and logon processes may be slower than expected.

Note The time that is required to start and log on to the computer increases when one or more of the following conditions are true:
  • The computer does not have cached IP addresses of the domain controller.
  • The computer does not have access to a working DNS server.
  • The DNS server that is available to the computer cannot resolve SRV records for the domain controller.
When domain controllers are unavailable, the computer tries four times to locate a domain controller, and an event is logged for each try. The event that is logged during the first try resembles the following:


The events that are logged during the second, third, and fourth attempts resemble the following:

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Cause

This issue occurs because the GetUserNameEx function tries to locate a domain controller three times after the first try fails. Then, the Group Policy engine has to retrieve the distinguished name of the policy target by calling the GetUserNameEx function. However, if a domain controller is not available, it is unnecessary for the function to try repeatedly to locate a domain controller.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

Important This hotfix has been re-released to address an issue in which the digital signature on files produced and signed by Microsoft will expire prematurely, as described in Microsoft Security Advisory 2749655.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Gpsvc.dll6.1.7601.22031593,92026-Jun-201204:21x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Gpsvc.dll6.1.7601.22031777,72826-Jun-201205:22x64
Gpapi.dll6.1.7601.2203179,87226-Jun-201204:21x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Gpapi.dll6.1.7601.22031168,96026-Jun-201204:21IA-64
Gpsvc.dll6.1.7601.220311,323,52026-Jun-201204:21IA-64
Gpapi.dll6.1.7601.2203179,87226-Jun-201204:21x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,136
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameX86_e38645cb6303a4035616e40089cb7fbe_31bf3856ad364e35_6.1.7601.22031_none_f1a803b8e0c5be49.manifest
File versionNot Applicable
File size704
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameX86_microsoft-windows-grouppolicy-base_31bf3856ad364e35_6.1.7601.22031_none_2a9ba5b35e75756e.manifest
File versionNot Applicable
File size135,849
Date (UTC)26-Jun-2012
Time (UTC)08:38
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_06bf5ac597462785787c05b7cacd7c5c_31bf3856ad364e35_6.1.7601.22031_none_b25f5312bfe5bd60.manifest
File versionNot Applicable
File size1,058
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameAmd64_4aa6f02465793b801c18362142ac08e5_31bf3856ad364e35_6.1.7601.22031_none_3b36bba8df8f716b.manifest
File versionNot Applicable
File size708
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameAmd64_dfe65bf710a7435b00be1f26d91c8fb9_31bf3856ad364e35_6.1.7601.22031_none_ede8134c51037ba8.manifest
File versionNot Applicable
File size708
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameAmd64_microsoft-windows-grouppolicy-base_31bf3856ad364e35_6.1.7601.22031_none_86ba413716d2e6a4.manifest
File versionNot Applicable
File size135,855
Date (UTC)26-Jun-2012
Time (UTC)08:54
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,773
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameWow64_microsoft-windows-grouppolicy-base_31bf3856ad364e35_6.1.7601.22031_none_910eeb894b33a89f.manifest
File versionNot Applicable
File size60,362
Date (UTC)26-Jun-2012
Time (UTC)04:52
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_ba00acba815f2b6b1e00bce89579637c_31bf3856ad364e35_6.1.7601.22031_none_8d825cc017283847.manifest
File versionNot Applicable
File size1,056
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameIa64_microsoft-windows-grouppolicy-base_31bf3856ad364e35_6.1.7601.22031_none_2a9d49a95e737e6a.manifest
File versionNot Applicable
File size130,896
Date (UTC)26-Jun-2012
Time (UTC)05:44
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,447
Date (UTC)17-Sep-2012
Time (UTC)16:24
PlatformNot Applicable
File nameWow64_microsoft-windows-grouppolicy-base_31bf3856ad364e35_6.1.7601.22031_none_910eeb894b33a89f.manifest
File versionNot Applicable
File size60,362
Date (UTC)26-Jun-2012
Time (UTC)04:52
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2673042
Revision : 1
Created on : 1/7/2017
Published on : 5/24/2013
Exists online : False
Views : 294