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The Channel service stops when a user signs in to a Group Chat client in Lync Server 2010, Group Chat


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Symptoms

Consider the following scenario:
  • You set up a Group Chat server pool that contains several Group Chat servers in a Microsoft Lync Server 2010 environment.
  • You configure the log level for the Channel service to Debug or Trace.
  • A user signs in to a Group Chat client.
In this scenario, the Channel service on the last started Group Chat Server in the Group Chat server pool stops. Additionally, the following events are logged in the Application log:

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Cause

This issue occurs because an object reference in a Group Chat function is set to a NULL when the function tries to determine whether the client is local or remote. This causes the Channel service to stop when the logging is set to a DEBUG level or a higher level.

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Resolution

To resolve this issue, install the following cumulative update:
2670342 Description of the cumulative update for Lync Server 2010, Group Chat: February 2012


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Workaround

To work around this issue, set the log level of the Channel service to INFO level on all Group Chat servers in the pool.

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More Information

For more information about how to set log levels for the Channel service, Lookup service, or Web service, visit the following Microsoft website:

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kb

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Article Info
Article ID : 2666342
Revision : 1
Created on : 1/7/2017
Published on : 3/1/2012
Exists online : False
Views : 178