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You cannot share an application or the desktop in Lync Web App


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Symptoms

Consider the following scenario:
  • You configure the External Web Services address and the Audio/Video Edge server address in a Microsoft Lync Server 2010 environment.
  • The DNS server cannot resolve the External Web Services address or the Audio/Video Edge server address. 
  • You use a proxy auto-configuration script to configure the proxy server settings in Windows Internet Explorer.
  • You start Microsoft Lync Web App and try to share an application or the desktop.
In this scenario, you cannot share the application or the desktop.

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Cause

This issue occurs because Lync Web App does not connect to the Audio/Video Edge server through a proxy server. This behavior occurs when Internet Explorer is configured to detect proxy server settings by using a configuration script.

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Resolution

To resolve this issue, install the following cumulative update:
2670534 Description of the cumulative update for Lync Server 2010, Web Components Server: February 2012


After the update is installed, you use one of the following methods to resolve the issue.

Method 1

  1. On the client computer, open Internet options,and then clear the browsing historyin the General tab.
  2. Delete all the XAP files in the following folder:
    %userprofile%\AppData\Local\Microsoft\Windows\Temporary Internet Files
  3. Close all Internet Explorer windows.
  4. Uninstall the Microsoft Lync Web App plug-in in Programs and Features.
  5. Start Lync Web App, and try to share an application or the desktop.
  6. Install the plugin when the webpage prompts you.

Method 2

Follow these steps on the Lync Server 2010 Front-End server:
  1. Open the ReachAppShPluginProperties.xml file in the following folder:
    %ProgramFiles%\Microsoft Lync Server 2010\Web Components\Reach\Int\Client\Plugins
  2. Change <MinSupportedBuildVersion value="4.0.7457.0" /> to <MinSupportedBuildVersion value="4.0.7577.380" />.
  3. Open the ReachAppShPluginProperties.xml file in the following folder:
    %ProgramFiles%\Microsoft Lync Server 2010\Web Components\Reach\Ext\Client\Plugins
  4. Change <MinSupportedBuildVersion value="4.0.7457.0" /> to <MinSupportedBuildVersion value="4.0.7577.380" />.
Then, follow these steps on the client computers:
  1. Open Internet options and clear the browsing history in the General tab.
  2. Delete all the XAP files in the following folder:
    %userprofile%\AppData\Local\Microsoft\Windows\Temporary Internet Files
  3. When you next start Lync Web App on the client computer, the webpage prompts to upgrade the plugin.

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Workaround

To work around this issue, manually configure the Internet Explorer proxy server settings.

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More Information

For more information about the Lync Web App features, visit the following Microsoft website:For more information about how to use the automatic configuration, automatic proxy, and automatic detection features in Internet Explorer, visit the following Microsoft website:

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2666326
Revision : 2
Created on : 9/21/2018
Published on : 9/21/2018
Exists online : False
Views : 241