Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a Get/Change error when you process timesheets in Personal Data Keeper


View products that this article applies to.

Symptom

After you apply the year-end update for Microsoft Dynamics GP, and you attempt to process timesheets in Personal Data Keeper (PDK) you receive the error message:  
A get/change operation on table 'GL_Account_MSTR' failed accessing SQL data.
More Info: Number of results columns doesn't match table definition.

↑ Back to the top


Cause

Personal Data Keeper and Microsoft Dynamics GP need to be on compatible versions. Then you need to synchronize the PDK dictionary.  

↑ Back to the top


Resolution

First verify that the PDK version is compatible with the Microsoft Dynamics GP version.

GP 10.0
GP versionPDK version
10.0.774 – 10.0.87210.00.19
10.0.903 – 10.0.99110.00.20
10.0.1061 – 10.0.112910.00.23 or 24 or 26
10.0.1061 (SP3) Canadian Payroll users10.00.26
10.0.1193 – 10.0.132810.00.24 or 26
10.0.1368 (SP4) - 10.0.150210.00.27
10.0.1579 (SP5) or 10.0.163410.00.31
10.0.1685 or 10.0.175710.00.32
10.0.1779 – current10.00.1809 or 10.00.1837
10.0.1779 Canadian Payroll users10.00.1837


GP 2010
GP versionPDK version
11.00.1307 – 11.00.152411.00.1315
11.0.158511.00.1525
11.0.166711.00.1662
11.0.1752 – 11.00.179911.00.1719 or 11.00.1806
11.0.1860 – current11.00.1863 or 11.00.1920
11.0.1860Canadian Payroll users11.00.1920


If you are not on a compatable version use the below link to obtain the correct service pack.


https://mbs.microsoft.com/customersource/downloads/servicepacks/MDGP2010_PDK_ServicePacksHotfixes.htm


Once you know compatible versions are being used, then do these steps:  

1. Find and open the Personal Data Keeper Dex.ini file.  To locate the Dex.ini file for Personal Data Keeper go to the Data folder in the Personal Data Keeper installation folder. By default the installation folder is C:\Program Files\Microsoft Dynamics\Personal Data Keeper.
2. Change the line that reads Synchronize=FALSE to be Synchronize=TRUE.

3. Save the file.

4. Start Personal Data Keeper and answer Yes to include new code if prompted.

5. When Personal Data Keeper closes, start it again and log in and verify that you are able to process timesheets.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kb

↑ Back to the top

Article Info
Article ID : 2663783
Revision : 1
Created on : 1/7/2017
Published on : 6/15/2012
Exists online : False
Views : 318