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You have to wait more than two minutes before you can access mapped drives when you wake a Windows 7-based computer from sleep


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have several mapped drives on a computer that is running Windows 7 or Windows Server 2008 R2.
  • You enable the Always available offline option on some mapped drives.
  • You put the computer to sleep.
  • You wake the computer from sleep.
In this scenario, you have to wait more than two minutes until you can access all the mapped drives. During this period, a red cross mark may appear on each mapped drive in Windows Explorer. Additionally, if you try to access the mapped drives, you may receive an error message that resembles one of the following:

An error occurred while reconnecting drive letter: to \\server\share\directory Microsoft Windows Network: The local device name is already in use. This connection has not been restored.

drive letter
: refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network. Check to make sure the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have moved to a different location.

An error occurred while reconnecting drive letter: to \\server\share\directory Microsoft Windows Network: The network location cannot be reached. For more information about network troubleshooting, see Windows Help. The connection has not been restored.

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Cause

This issue occurs because the client-side caching (CSC) interface tries to reconnect to the source before the network is actually available. This behavior causes the SMB cache to enter a negative state. In this situation, the CSC interface tries to reconnect to the source on the next 2-minute retry interval.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Cscsvc.dll6.1.7601.21896547,32812-Jan-201206:02x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cscsvc.dll6.1.7601.21896693,76012-Jan-201206:25x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_06ad98a8c83fc505dbb50409a5ec0950_31bf3856ad364e35_6.1.7601.21896_none_ca3cf34e981af8b6.manifest
File versionNot Applicable
File size708
Date (UTC)12-Jan-2012
Time (UTC)12:10
PlatformNot Applicable
File nameX86_microsoft-windows-offlinefiles-service_31bf3856ad364e35_6.1.7601.21896_none_0c101dc0d8ff09d3.manifest
File versionNot Applicable
File size56,703
Date (UTC)12-Jan-2012
Time (UTC)06:32
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_e4420fb86739b261eb9c7c5b443a3d0b_31bf3856ad364e35_6.1.7601.21896_none_0be60fa7ff77a384.manifest
File versionNot Applicable
File size712
Date (UTC)12-Jan-2012
Time (UTC)12:10
PlatformNot Applicable
File nameAmd64_microsoft-windows-offlinefiles-service_31bf3856ad364e35_6.1.7601.21896_none_682eb944915c7b09.manifest
File versionNot Applicable
File size56,710
Date (UTC)12-Jan-2012
Time (UTC)07:37
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2663418
Revision : 1
Created on : 3/21/2017
Published on : 2/16/2012
Exists online : False
Views : 264