Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

MPIO does not remove a disk that is on a failed path in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable the Microsoft Multipath I/O (MPIO) feature on a computer that is running Windows Server 2008 R2.
  • You connect a disk to the computer by using multipath cables.
  • You call the GetPathConfiguration�WMI�function to retrieve the device information for available paths.
  • A path failure occurs on one path. For example, you disconnect one of the multipath cables.
In this scenario, MPIO does not remove the disk that is on the failed path. Additionally, Device Manager stops responding. The path is not restored even if you reconnect the cable. Therefore, you must restart the computer to recover from the issue.

↑ Back to the top


Cause

This issue occurs because the reference count on the MPIO disk object is incremented and never decremented when you call the�GetPathConfiguration�WMI function.�

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mpio.sys6.1.7601.17760156,52812-Jan-201206:52x64
Mpio.sys6.1.7601.21896158,06412-Jan-201206:37x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mpio.sys6.1.7601.17760350,57612-Jan-201205:22IA-64
Mpio.sys6.1.7601.21896357,74412-Jan-201205:32IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about multipath I/O (MPIO), visit the following Microsoft website:For more information about the GetPathConfiguration function, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_mpio.inf_31bf3856ad364e35_6.1.7601.17760_none_7b1ed512a61fea56.manifest
File versionNot applicable
File size2,073
Date (UTC)12-Jan-2012
Time (UTC)07:20
File nameAmd64_mpio.inf_31bf3856ad364e35_6.1.7601.21896_none_7b8e03d5bf5075fd.manifest
File versionNot applicable
File size2,073
Date (UTC)12-Jan-2012
Time (UTC)07:35
File nameUpdate.mum
File versionNot applicable
File size2,070
Date (UTC)12-Jan-2012
Time (UTC)12:14
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_mpio.inf_31bf3856ad364e35_6.1.7601.17760_none_1f01dd84edc0821c.manifest
File versionNot applicable
File size2,071
Date (UTC)12-Jan-2012
Time (UTC)06:54
File nameIa64_mpio.inf_31bf3856ad364e35_6.1.7601.21896_none_1f710c4806f10dc3.manifest
File versionNot applicable
File size2,071
Date (UTC)12-Jan-2012
Time (UTC)07:20
File nameUpdate.mum
File versionNot applicable
File size1,451
Date (UTC)12-Jan-2012
Time (UTC)12:14

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2661794

↑ Back to the top

Article Info
Article ID : 2661794
Revision : 1
Created on : 2/16/2012
Published on : 2/16/2012
Exists online : False
Views : 258