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The whole backup operation fails if one out of several virtual machines on a Hyper-V server cannot be backed up in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have multiple virtual machines on a Hyper-V server that is running Windows Server 2008 R2.
  • You back up these virtual machines by using a backup application that performs a Volume Shadow Copy Service (VSS) backup operation.
    Note The “%system drive%\ProgramData\Microsoft\Windows\Hyper-V\InitialStore.xml” file is not included in the backup operation.
  • One of the virtual machines cannot be backed up.
  • Other virtual machines are not in running state.
In this scenario, the whole backup operation fails. The expected behavior is for the Hyper-V VSS writer to report a "PARTIAL FAILURE" error when one of the virtual machines cannot be backed up. The backup operation is supposed to exclude this virtual machine, and then continue to back up the other virtual machines.

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Cause

This issue occurs because the Hyper-V VSS writer returns an incorrect "VSS_E_WRITERERROR_RETRYABLE" error to the backup application. This behavior causes the backup application to retry the backup operation. After the backup operation tries and then fails multiple times, the whole backup operation fails.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimeHashesPlatform
Vmms.exe6.1.7601.218984,628,48014-Jan-201204:09MD5: 2AB1B63F5AECB0693D7A941348C89F16
SHA1: 8ECE98F0474E05964A6EFA1ACB64A7C7E1DCCEDE
x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about how to back up and restore virtual machines, visit the following Microsoft website:
For more information about the IVssBackupComponentsEx3::GetWriterStatusEx method, visit the following Microsoft website:

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_0547b9ff6a53437a72df8e0f4cc46010_31bf3856ad364e35_6.1.7601.21898_none_2eaebc3a559626ce.manifest
File versionNot applicable
File size703
Date (UTC)14-Jan-2012
Time (UTC)12:19
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameAmd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.1.7601.21898_none_94f32f6e8ee71ef9.manifest
File versionNot applicable
File size341,338
Date (UTC)14-Jan-2012
Time (UTC)09:49
SHA-1 hashNot applicable
MD5 hashNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2661530
Revision : 1
Created on : 1/7/2017
Published on : 1/4/2013
Exists online : False
Views : 168