Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Deadlocks occur on an instance of SQL Server that hosts a Commerce Server 2009 transactions database


View products that this article applies to.

Symptoms

Deadlocks may occur intermittently on an instance of Microsoft SQL Server that hosts a Microsoft Commerce Server 2009 transactions database.

Note This issue typically occurs when frequent search operations are performed on purchase orders.

↑ Back to the top


Cause

The issue occurs because additional indexes are needed in the Searchresult table of the transactions database.

↑ Back to the top


Resolution

To resolve this issue, apply the following hotfix. After you apply the hotfix, additional indexes are created in the Searchresult table.

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have Microsoft Commerce Server 2009 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

Installation steps

This hotfix package contains the following files:
  • CommerceServer2007SP3-KB2658261-ENU.exe
  • KB2658261.sql
  • Hotfix.txt
Notes
  • To prevent the occurrence of this issue in new transactions databases, run the CommerceServer2007SP3-KB2658261-ENU.exe file to update the Requisition.sql file for Commerce Server 2009.
  • To resolve this issue in existing Commerce Server sites, run the KB2658261.sql file against the existing transactions databases.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
requisition.sqlNot applicable103,88220-Dec-201108:48Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2658261
Revision : 1
Created on : 1/7/2017
Published on : 4/21/2013
Exists online : False
Views : 346