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"The system cannot find the file specified" error message when you print a document on a Windows Server 2008-based terminal server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You establish a Terminal Services session to a Windows Server 2008-based terminal server that has Windows Internet Explorer 9 installed.
  • You do not redirect a printer to the Terminal Services session.
  • You run an application that hosts Internet Explorer 9 and that is compiled through the functionality of the /TSAWARE:NO option on the terminal server.
  • You try to print a document to a network printer by using this application.
In this scenario, the printer does not print the document. Additionally, you receive an error message that resembles the following:
The system cannot find the file specified.

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Cause

This issue occurs because the FOLDERID_FONTS value points to an incorrect directory.  The value should point to the following directory:
C:\Windows\Fonts
However, the value points to the following directory instead:
C:\Users\%username%\Windows\Fonts

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 Service Pack 2 (SP2).For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTime
Shell32.dll6.0.6002.2277411,587,58409-Jan-201215:36
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.0.6002.2277412,901,88809-Jan-201218:28x64
Shell32.dll6.0.6002.2277411,587,58409-Jan-201215:36x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameX86_63e0b7298b1c25957a4eaf937a0b70ae_31bf3856ad364e35_6.0.6002.22774_none_ee2cd36d4cc6ab4f.manifest
File versionNot applicable
File size695
Date (UTC)10-Jan-2012
Time (UTC)06:50
File nameX86_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22774_none_6e519c5b2874f1ff.manifest
File versionNot applicable
File size904,280
Date (UTC)09-Jan-2012
Time (UTC)15:56
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_793f58c5f44841ba8971b3a7650850f9_31bf3856ad364e35_6.0.6002.22774_none_8fe20a06cdaca7f6.manifest
File versionNot applicable
File size1,040
Date (UTC)10-Jan-2012
Time (UTC)06:50
File nameAmd64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22774_none_ca7037dee0d26335.manifest
File versionNot applicable
File size906,212
Date (UTC)09-Jan-2012
Time (UTC)18:42
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22774_none_d4c4e23115332530.manifest
File versionNot applicable
File size899,183
Date (UTC)09-Jan-2012
Time (UTC)15:43

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2656827
Revision : 1
Created on : 1/7/2017
Published on : 2/27/2012
Exists online : False
Views : 226