Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot search for a user when you try to add the user to a chat room in Office Communications Server 2007 R2, Group Chat Administrator Tool


Symptoms

Consider the following scenario:
  • You sign in to Microsoft Office Communications Server 2007 R2, Group Chat Administrator Tool.
  • There is a user in a nested Distribution List (DL) or a DL that contains lots of members.
  • You try to add the user to a Chat Room.
  • You type an incomplete user name under the Add User to Role dialog box, and then click Search.
In this scenario, Group Chat Administrator Tool does not show the search results. Additionally, you receive the following error message:
Unable to get eligible principals: Operation failure

↑ Back to the top


Cause

This issue occurs because of a time-out error that occurs when Group Chat Administrator Tool performs a LDAP search across the LDAP database within the DL. The time-out value for a search is 15 seconds.

↑ Back to the top


Resolution

To resolve this issue, install the following cumulative update:
2647088 Description of the cumulative update for the Office Communications Server 2007 R2 Group Chat Administration Tool: January, 2012


After the update is installed, the time-out value for searches is set to 120 seconds.

↑ Back to the top


Keywords: kbqfe, kbsurveynew, kbfix, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2653952
Revision : 1
Created on : 1/7/2017
Published on : 1/19/2012
Exists online : False
Views : 80