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Computer name is displayed in the wrong language in the "Devices and Printers" Control Panel item in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You start a computer that has Windows 7 or Windows Server 2008 R2 preinstalled for the first time.
  • You set the display language to Russian, Arabic, or Hebrew in the Out of Box Experience (OOBE) Wizard.
  • You enter a computer name in the language that you set in the OOBE Wizard.
  • You finish running the OOBE Wizard and enter the system.
In this scenario, the computer name in the Devices and Printers Control Panel item is displayed in English instead of the language that you set in the OOBE Wizard.

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Cause

This issue occurs because the conversion from Unicode characters to English characters fails. Therefore, the computer name that you entered in the OOBE Wizard is not set in the registry that is used by the Devices and Printers Control Panel item.

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Resolution

To resolve this issue, use one of the following methods on the affected computer that runs the OOBE Wizard:
  • Manually modify the computer name in the following registry subkeys:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerName\ComputerName
  • Manually modify the computer name in the System Properties dialog box.
Note Install the hotfix in the installation image to prevent this problem occurring during the setup process. After you have installed Windows and this issue has occured, you cannot repair the computer name by installing this hotfix.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Installation instructions for how to apply the hotfix package

To apply this hotfix package, follow these steps:
  1. Download all the necessary files and tools.
    1. Install the Windows 7 OEM Preinstallation Kit (OPK).
    2. Copy the hotfix package to a folder on the computer. For example, copy the package to the C:\test\updates folder.
    3. Copy the Install.wim file from the Windows 7 installation media or from the Windows Server 2008 R2 installation media to the computer. For example, copy the Install.wim file to the C:\test\images folder.
  2. Add the hotfix to a Windows 7 image or to a Windows Server 2008 R2 image. To do this, follow these steps:
    1. Click Start, and then click All Programs. Then, click Windows OPK, right-click Deployment Tools Command Prompt, and then click Run as administrator.
    2. At the command prompt, retrieve the name or the index number for the image that you want to change. To do this, type the following command, and then press ENTER:
      Dism /Get-WIMInfo /WimFile:C:\test\images\install.wim
    3. Note the index number or the name of the image to which you will add the hotfix. The image is either a Windows 7 image or a Windows Server 2008 R2 image.
    4. Use a DISM command to mount the image by using the index number or the name that was noted in step 2C. For example, if the index number of the image to which you will add the hotfix is 3, use the following command to mount Index 3 to a folder that is named "offline" in the test directory:
      Dism /Mount-Wim /WimFile:C:\test\images\install.wim /Index:3 /MountDir:C:\test\offline  
      Note You must create the C:\test\offline folder before you mount the image.

    5. At the command prompt, type the appropriate command to add the hotfix, and then press ENTER.

      Type the following command for x86-based versions of Windows 7:
      Dism /Image:C:\test\offline /Add-Package /PackagePath:C:\test\updates\Windows6.1-KB2652029-x86.msu
      Type the following command for x64-based versions of Windows 7 and Windows Server 2008 R2:
      Dism /Image:C:\test\offline /Add-Package /PackagePath:C:\test\updates\Windows6.1-KB2652029-x64.msu
      Type the following command for IA-64-based versions of Windows 7 and Windows Server 2008 R2:
      Dism /Image:C:\test\offline /Add-Package /PackagePath:C:\test\updates\Windows6.1-KB2652029-ia64.msu
    6. At the command prompt, type the following command to commit the changes and to unmount the image:
      Dism /Unmount-WIM /MountDir:C:\test\offline /Commit

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Msoobeui.dll6.1.7601.177611,115,64813-Jan-201207:11x86
Msoobeui.dll6.1.7601.218971,115,64813-Jan-201207:24x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Msoobeui.dll6.1.7601.177611,162,24013-Jan-201208:17x64
Msoobeui.dll6.1.7601.218971,162,24013-Jan-201208:11x64
For all supported IA-64–based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Msoobeui.dll6.1.7601.177611,519,10413-Jan-201206:39IA-64
Msoobeui.dll6.1.7601.218971,519,10413-Jan-201206:52IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate-bf.mum
File versionNot applicable
File size1,421
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameX86_080d0c6145f003ff307bae941b89b64c_31bf3856ad364e35_6.1.7601.21897_none_a1f19e7299dee175.manifest
File versionNot applicable
File size703
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameX86_921aa3c031a0a2f2afd3eed58fc73ca8_31bf3856ad364e35_6.1.7601.17761_none_04edad6e0dd58d0c.manifest
File versionNot applicable
File size703
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameX86_microsoft-windows-oobe-machine-ui_31bf3856ad364e35_6.1.7601.17761_none_64298b6b401e0bd3.manifest
File versionNot applicable
File size14,299
Date (UTC)13-Jan-2012
Time (UTC)07:41
PlatformNot applicable
File nameX86_microsoft-windows-oobe-machine-ui_31bf3856ad364e35_6.1.7601.21897_none_6498ba2e594e977a.manifest
File versionNot applicable
File size14,299
Date (UTC)13-Jan-2012
Time (UTC)07:53
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_2da7bbf13283f32b04e416777f62b562_31bf3856ad364e35_6.1.7601.17761_none_dee53a6335d2d0e6.manifest
File versionNot applicable
File size707
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameAmd64_e508c62f069a50571c7228bea00fb135_31bf3856ad364e35_6.1.7601.21897_none_48e30f9ac7bffcbf.manifest
File versionNot applicable
File size707
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameAmd64_microsoft-windows-oobe-machine-ui_31bf3856ad364e35_6.1.7601.17761_none_c04826eef87b7d09.manifest
File versionNot applicable
File size14,303
Date (UTC)13-Jan-2012
Time (UTC)08:57
PlatformNot applicable
File nameAmd64_microsoft-windows-oobe-machine-ui_31bf3856ad364e35_6.1.7601.21897_none_c0b755b211ac08b0.manifest
File versionNot applicable
File size14,303
Date (UTC)13-Jan-2012
Time (UTC)08:58
PlatformNot applicable
File nameUpdate-bf.mum
File versionNot applicable
File size1,429
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
File nameIa64_14ecade9bdb84f92c15212bb0c83b4b0_31bf3856ad364e35_6.1.7601.17761_none_5215bab714b6e551.manifest
File versionNot applicable
File size705
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameIa64_4554764cc2ec2d09b8e1856c306898ad_31bf3856ad364e35_6.1.7601.21897_none_dedd7b224849f16e.manifest
File versionNot applicable
File size705
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable
File nameIa64_microsoft-windows-oobe-machine-ui_31bf3856ad364e35_6.1.7601.17761_none_642b2f61401c14cf.manifest
File versionNot applicable
File size14,301
Date (UTC)13-Jan-2012
Time (UTC)08:24
PlatformNot applicable
File nameIa64_microsoft-windows-oobe-machine-ui_31bf3856ad364e35_6.1.7601.21897_none_649a5e24594ca076.manifest
File versionNot applicable
File size14,301
Date (UTC)13-Jan-2012
Time (UTC)08:37
PlatformNot applicable
File nameUpdate-bf.mum
File versionNot applicable
File size1,425
Date (UTC)13-Jan-2012
Time (UTC)16:54
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2652029
Revision : 1
Created on : 1/7/2017
Published on : 1/4/2013
Exists online : False
Views : 206