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Applications Fail to Install, even when logged on as an Administrator


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Symptoms

Various applications may fail to install, even though you are logged on as an administrator. Windows event logs may or may not give helpful information about the cause of the problem.

A user who is a member of a computer’s local administrator group, logs on to a computer with the intent of installing an application. The application installation begins, but soon fails. An error might be displayed, or a link to a log file might be displayed. In some cases the cause may be a standard Windows error code.

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Cause

It may be possible that some application is holding a handle or exclusive lock to the following Windows registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\ServiceModelService 3.0.0.0

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Resolution

To resolve this issue, first, determine what software is holding a handle open to the “ServiceModelService 3.0.0.0” registry key.

Download Handle.exe from the following location on Microsoft.com:
http://technet.microsoft.com/en-us/sysinternals/bb896655

  1. From an administrator elevated command prompt, run the Handle.exe utility.

    NOTE: If you have not run Handle.exe previously, you will be prompted with an End-User License Agreement. If acceptable, click the “Agree” button.
  2. Save the output from Handle.exe to a text file for analysis, but running this command:

    Handle –a > <path>\Handles.txt

    NOTE: You can enter any path, or do not enter a path and the output file will be created in the current directory
  3. Open the Handle.exe output, by running this command:

    Notepad Handle.txt
  4. In Notepad, search for the string “ServiceModelService” (without quotation marks)
  5. If a handle is found that is open to the “ServiceModelService 3.0.0.0” registry key, the output will look something like this:

    4F0: Key HKLM\SYSTEM\ControlSet001\services\ServiceModelService 3.0.0.0\Performance
  6. Scroll up in the Handle.txt output file until you find the process that created this handle. The output might look something like this: 

    WmiPrvSE.exe pid: 3340 NT AUTHORITY\NETWORK SERVICE

    NOTE: In some cases the process might be a service, or it might be some other kind of software. If the software is as listed in step 6, the WMIPRVSE.EXE service, which is the WMI Provider service, you might want to continue going through the Handle.txt output file to see if some other software is holding open handles to the “ServiceModelService 3.0.0.0” registry key.
  7. If you find the only process holding a handle open to the ““ServiceModelService 3.0.0.0” registry key is the WMIPRVSE service, the best course of action may be to perform clean-boot troubleshooting, per the following Microsoft Knowledge Base Article:

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
    http://support.microsoft.com/kb/929135

    NOTE: Though the Clean-Boot Troubleshooting article specifically calls out Windows Vista or Windows 7, the information is equally applicable to Windows Server 2008, or Windows Server 2008 R2.

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Keywords: kb

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Article Info
Article ID : 2651794
Revision : 2
Created on : 8/1/2019
Published on : 8/1/2019
Exists online : False
Views : 337