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Boot program fails when you try to install Windows by using a WDS server that is running Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you start a Pre-Boot Execution Environment (PXE) Extensible Firmware Interface (EFI)-based client computer, and then you connect it to a Windows Deployment Service (WDS) server that is running Windows Server 2008 R2. The client computer has a network adapter that does not support Multicast. When you try to run the boot program, the program fails, and you cannot deploy Windows to the client computer.

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Cause

This issue occurs because an error occurs when WDS tries to disable Multicast.

Note This issue occurs only when the network adapter on the client computer does not support Multicast.

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Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Bootmgfw.efi6.1.7601.21894673,13609-Jan-201214:38
Wdsmgfw.efi6.1.7601.21894532,48009-Jan-201211:44

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

You must apply this hotfix to the second image of the Windows Vista or Windows Server 2008 boot image file. To do this, follow these steps.

Note The second image is the Windows Preinstallation Environment (Windows PE) image.
  1. On the Windows Deployment Services server, install Windows Automated Installation Kit (AIK) for Windows 7. To obtain Windows AIK for Windows 7, visit the following Microsoft website: Note You can also install Windows AIK for Windows 7 on a separate computer that is running an operating system that is supported by Windows AIK for Windows 7.
  2. Click Startstart button , click All Programs, click Microsoft Windows AIK, right-click Deployment Tools Command Prompt, and then click Run as administrator.

    UAC If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
  3. Extract the Windows6.0-KB2649909-v2-Platform.cab file from the hotfix package to a temporary folder. To do this, follow these steps:
    1. Click Startstart button , click Run, type cmd, and then click OK.
    2. At the command prompt, type the following command, and then press ENTER:
      Expand.exe CabFilePath -R -F:* TempFolderPath
      Notes
      • The CabFilePath placeholder represents the path of the CAB file.
      • The TempFolderPath placeholder represents the path of the temporary folder.
  4. Disable the problematic boot image to make it unavailable for download in the update process. To do this, open the Windows Deployment Services Microsoft Management Console (MMC) snap-in, right-click the boot image that you want to update, and then click Disable.
  5. Export the boot image that must be updated from the Windows Deployment Services server to BootWimPath. To do this, right-click the boot image, and then click Export Image. Export the boot image to BootWimPath.

    Notes
    • The BootWimPath placeholder represents the local directory to which the Boot.wim file is exported.
    • If you install Windows AIK on a separate computer, you must copy the Boot.wim file to a directory on that computer. Then, perform steps 6 through 8 on that computer.
  6. Mount the boot image for read/write permission. To do this, type the following command at a command prompt, and then press ENTER:
    dism /mount-wim /wimfile:BootWimPath /index:2 /mountdir:MountLocation
    Notes
    • The MountLocation placeholder represents the location in which to mount the image.
    • Make sure that you mount the image whose boot index number is 2.
  7. Copy the Wdsmgfw.efi file from the TempFolderPath folder to the following folder:
    MountLocation\Windows\Boot\PXE
  8. Copy the Bootmgfw.efi file from the TempFolderPath folder to the following folder:
    MountLocation\Windows\Boot\EFI
  9. Unmount the Boot.wim file, and then commit all changes. To do this, type the following command at a command prompt, and then press ENTER:
    Dism.exe /unmount-wim /mountdir:MountLocation /commit
  10. Add the updated Boot.wim file back to the Windows Deployment Services server. To do this, open the Windows Deployment Services MMC snap-in, right-click Boot Images, click Add Boot Image, and then specify the path of the updated Boot.wim file.
  11. In the Windows Deployment Services MMC snap-in, right-click the boot image that you added to make sure that it is enabled.
For more information about Windows Deployment Services, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2649909
Revision : 4
Created on : 4/10/2020
Published on : 4/10/2020
Exists online : False
Views : 217