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Winsock-based operations fail in Windows 7 or in Windows Server 2008 R2 if the executable file is located on an NFS share


View products that this article applies to.

Symptoms

Assume that you try to start a Windows Sockets (Winsock)-based application on a computer that is running Windows 7 or Windows Server 2008 R2. If the executable file is located on a Network File System (NFS) share in which the share name contains a path separator such as /root/share, Winsock-based operations fail. Additionally, you receive a Winsock error code. For example, you receive one of the following error codes: 
WSAEINVAL (10022)
WSANO_RECOVERY (11003)

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Cause

This issue occurs because of a change in the behavior of Windows Filtering Platform (WFP) that was implemented in Windows 7 and in Windows Server 2008 R2.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Nfs-clientcore-ppdlic.xrm-msNot Applicable3,00130-Nov-201105:54Not Applicable
Nfsclnt.exe6.1.7601.2186952,73630-Nov-201105:19x86
Nfsnp.dll6.1.7601.2186959,90430-Nov-201105:22x86
Nfsrdr.sys6.1.7601.21869202,24030-Nov-201103:15x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Nfs-clientcore-ppdlic.xrm-msNot Applicable3,00130-Nov-201106:39Not Applicable
Nfsclnt.exe6.1.7601.2186965,53630-Nov-201106:14x64
Nfsnp.dll6.1.7601.2186971,68030-Nov-201106:18x64
Nfsrdr.sys6.1.7601.21869247,29630-Nov-201103:34x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Nfs-clientcore-ppdlic.xrm-msNot Applicable3,00130-Nov-201105:38Not Applicable
Nfsclnt.exe6.1.7601.21869156,16030-Nov-201105:11IA-64
Nfsnp.dll6.1.7601.21869159,23230-Nov-201105:14IA-64
Nfsrdr.sys6.1.7601.21869587,77630-Nov-201102:59IA-64

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Workaround

To work around this issue, change all the names in the share path to have at least eight characters.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about Winsock error codes, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_6888d19e17c659a4d1c9307ee16c7cb0_31bf3856ad364e35_6.1.7601.21869_none_8d5a637b1e427004.manifest
File versionNot Applicable
File size702
Date (UTC)30-Nov-2011
Time (UTC)17:37
File nameX86_microsoft-windows-nfs-clientcore_31bf3856ad364e35_6.1.7601.21869_none_af42790dba17d3af.manifest
File versionNot Applicable
File size28,372
Date (UTC)30-Nov-2011
Time (UTC)06:18
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_9d46965bb42af5c8ee72e8756cbc7ab1_31bf3856ad364e35_6.1.7601.21869_none_fcb0c7c89da2be95.manifest
File versionNot Applicable
File size706
Date (UTC)30-Nov-2011
Time (UTC)17:37
File nameAmd64_microsoft-windows-nfs-clientcore_31bf3856ad364e35_6.1.7601.21869_none_0b611491727544e5.manifest
File versionNot Applicable
File size28,376
Date (UTC)30-Nov-2011
Time (UTC)07:01
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_7fb877005c8ce80ffee1fed947581d3e_31bf3856ad364e35_6.1.7601.21869_none_b8886a8a9400f255.manifest
File versionNot Applicable
File size704
Date (UTC)30-Nov-2011
Time (UTC)17:37
File nameIa64_microsoft-windows-nfs-clientcore_31bf3856ad364e35_6.1.7601.21869_none_af441d03ba15dcab.manifest
File versionNot Applicable
File size28,374
Date (UTC)30-Nov-2011
Time (UTC)06:42

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2649107
Revision : 1
Created on : 1/7/2017
Published on : 1/11/2012
Exists online : False
Views : 285