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You cannot install RDS CALs automatically by using Windows PowerShell in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Remote Desktop Licensing (RD Licensing) role service on a computer that is running Windows Server 2008 R2.
  • You install hotfix package 2618115 on the computer.
  • You try to install Remote Desktop Services client access licenses (RDS CALs) automatically by using Windows PowerShell.
  • You select Telephone or Web Browser as the connection method.
  • The RD Licensing server does not have an active Internet connection.
In this scenario, you cannot install RDS CALs and you receive the following message:
Access to the object at RDS:\LicenseServer\LicenseKeyPacks\LicenseKeyPack is denied for the cmdlet New-Item. A license key pack could not be created because the input was not valid or permissions were insufficient.

At line:1 char:9

+ New-Item <<<< -path RDS:\LicenseServer\LicenseKeyPacks -ConnectionMethod PW

+ CategoryInfo : PermissionDenied: (:) [New-Item], AccessViolationException + FullyQualifiedErrorId : PermissionDenied,Microsoft.PowerShell.Commands.NewItemCommand

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Cause

This issue occurs because the RD Licensing server unnecessarily checks whether it is authenticated or not. This behavior requires Internet access. Therefore, the authentication check fails if the RD Licensing server does not have an active Internet connection.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2
This hotfix is dependent on hotfix 2618115. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2618115 You cannot activate an RD Licensing server or install RDS CALs automatically by using Windows PowerShell in Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760 0 . 16xxxWindows Server 2008 R2RTMGDR
    6.1.760 0 . 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Licmgr.exe6.1.7600.16385410,62414-Jul-200901:39x64
Lrwizdll.dll6.1.7600.21097586,24024-Nov-201107:14x64
Lserver_pkconfig.xmlNot applicable20,99411-Nov-200923:30Not applicable
Licmgr.exe6.1.7601.17514410,62420-Nov-201013:24x64
Lrwizdll.dll6.1.7601.21866586,75224-Nov-201107:08x64
Lserver_pkconfig.xmlNot applicable20,99405-Nov-201001:57Not applicable

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Workaround

To work around this issue, use either or both the following methods:
  • Connect the server to the Internet and then run the Windows PowerShell command again.
  • If the computer does not have an active Internet connection, use the RD Licensing Manager console to select the Telephone or Web Browser on the Connection method tab.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_4853300404aae42e01ed5f9baeefe55c_31bf3856ad364e35_6.1.7600.21097_none_c67b74171c7402f8.manifest
File versionNot applicable
File size727
Date (UTC)24-Nov-2011
Time (UTC)16:42
PlatformNot applicable
File nameAmd64_559fd094b9ae753be338c95787e9a71c_31bf3856ad364e35_6.1.7601.21866_none_36392be73b6017a5.manifest
File versionNot applicable
File size727
Date (UTC)24-Nov-2011
Time (UTC)16:42
PlatformNot applicable
File nameAmd64_microsoft-windows-t..-licensingadminpack_31bf3856ad364e35_6.1.7600.21097_none_a0b5a4c1e25a5b6a.manifest
File versionNot applicable
File size5,083
Date (UTC)24-Nov-2011
Time (UTC)16:42
PlatformNot applicable
File nameAmd64_microsoft-windows-t..-licensingadminpack_31bf3856ad364e35_6.1.7601.21866_none_a2bb9b05df692411.manifest
File versionNot applicable
File size5,083
Date (UTC)24-Nov-2011
Time (UTC)16:42
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,963
Date (UTC)24-Nov-2011
Time (UTC)16:42
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2648662

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Article Info
Article ID : 2648662
Revision : 2
Created on : 1/4/2013
Published on : 1/4/2013
Exists online : False
Views : 1043