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An application that uses the filter driver cannot intercept any incoming or outgoing packets by using a Bluetooth device that supports the tethering feature in Windows 7


View products that this article applies to.

Symptoms

Considering the following scenario:
  • You have an application that uses the Network Driver Interface Specification (NDIS) intermediate (IM) filter driver or the NDIS Light Weight Filter (LWF) driver to implement network control or other related functions on a computer that is running Windows 7.
  • You have a Bluetooth device that supports the tethering feature.
  • The Bluetooth device is connected to the Internet.
  • You create a Personal Area Network (PAN) connection between the device and the computer by using Bluetooth.
In this scenario, the application that uses the filter driver cannot intercept any incoming or outgoing packets. Therefore, the packets cannot be filtered according to the configured policy.

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Cause

This issue occurs because the NDIS IM filter driver and the LWF driver cannot bind to the Bluetooth PAN driver. This behavior occurs because the value of the LowerRange entry is set to nolower in the INF file.

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Resolution

After you install the hotfix, you must reinstall the driver for the Bluetooth device in order to resolve this issue.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows 7 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows 7RTMGDR
    6.1.760
    0.21xxx
    Windows 7RTMLDR
    6.1.760
    1.17xxx
    Windows 7SP1GDR
    6.1.760
    1.21xxx
    Windows 7SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Bthpan.sys6.1.7600.1692093,69624-Nov-201104:48x86
Bthpan.sys6.1.7600.2109793,69624-Nov-201104:51x86
Bthpan.sys6.1.7601.1773093,69624-Nov-201104:49x86
Bthpan.sys6.1.7601.2186693,69624-Nov-201104:45x86
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Bthpan.sys6.1.7600.16920118,78424-Nov-201105:31x64
Bthpan.sys6.1.7600.21097118,78424-Nov-201105:23x64
Bthpan.sys6.1.7601.17730118,78424-Nov-201105:27x64
Bthpan.sys6.1.7601.21866118,78424-Nov-201105:20x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about intermediate driver UpperRange and LowerRange INF file entries, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameX86_bthpan.inf_31bf3856ad364e35_6.1.7600.16920_none_8d6b7295cf1272a2.manifest
File versionNot Applicable
File size2,081
Date (UTC)24-Nov-2011
Time (UTC)07:15
File nameX86_bthpan.inf_31bf3856ad364e35_6.1.7600.21097_none_8db0382ee862bd7f.manifest
File versionNot Applicable
File size2,081
Date (UTC)24-Nov-2011
Time (UTC)07:16
File nameX86_bthpan.inf_31bf3856ad364e35_6.1.7601.17730_none_8f46ffafcc40fa7f.manifest
File versionNot Applicable
File size2,081
Date (UTC)24-Nov-2011
Time (UTC)07:15
File nameX86_bthpan.inf_31bf3856ad364e35_6.1.7601.21866_none_8fb62e72e5718626.manifest
File versionNot Applicable
File size2,081
Date (UTC)24-Nov-2011
Time (UTC)07:15
Additional files for all supported x64-based versions of Windows 7
File nameAmd64_bthpan.inf_31bf3856ad364e35_6.1.7600.16920_none_e98a0e19876fe3d8.manifest
File versionNot Applicable
File size2,085
Date (UTC)24-Nov-2011
Time (UTC)08:15
File nameAmd64_bthpan.inf_31bf3856ad364e35_6.1.7600.21097_none_e9ced3b2a0c02eb5.manifest
File versionNot Applicable
File size2,085
Date (UTC)24-Nov-2011
Time (UTC)08:10
File nameAmd64_bthpan.inf_31bf3856ad364e35_6.1.7601.17730_none_eb659b33849e6bb5.manifest
File versionNot Applicable
File size2,085
Date (UTC)24-Nov-2011
Time (UTC)08:11
File nameAmd64_bthpan.inf_31bf3856ad364e35_6.1.7601.21866_none_ebd4c9f69dcef75c.manifest
File versionNot Applicable
File size2,085
Date (UTC)24-Nov-2011
Time (UTC)08:03

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2647878
Revision : 1
Created on : 3/21/2017
Published on : 1/11/2012
Exists online : False
Views : 245