Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Various issues after you restore a system state backup that is saved by using VSS if the "ImagePath" value for a service contains a forward slash (/) in Windows Vista, Windows 7, Windows Server 2008, or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A service installs an "ImagePath" value in the registry on a computer that is running one of the following operating systems:
    • Windows Vista
    • Windows Server 2008
    • Windows 7
    • Windows Server 2008 R2
  • The file path in the value uses a forward slash (/) instead of a backslash (\) as the directory delimiter. For example, the file path is %program files%/software/bin/service.exe.
  • You perform a system state backup by using the Volume Shadow Copy Service (VSS).
  • You restore the system state by using the backup.
In this scenario, the restored operating system enters an indeterminate state. Therefore, you may experience some operating system failures. For example, the following failures may occur:
  • The computer crashes.
  • A black screen is displayed.
  • A warning is displayed that indicates that one or more of the boot files are missing or corrupted.

↑ Back to the top


Cause

This issue occurs because of the forward slash (/) that is used as the directory delimiter in a System Image Path registry entry. The VSS System Writer treats a forward slash (/) as an invalid character. This behavior causes the VSS System Writer to stop enumerating the rest of the files that should be included in the VSS System Writer metadata document. Therefore, many files are missing when you restore the system state backup.

↑ Back to the top


Resolution

Windows 7 and Windows Server 2008 R2

A fix for this issue is included in update 2703425. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2703425 A .pfx certificate file that does not have a private key is created when you cancel the Certificate Export Wizard on a computer that is running Windows 7 or Windows Server 2008 R2

Windows Vista and Windows Server 2008

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
For information about how to obtain the Windows Vista service pack, see the following Windows website: For information about how to obtain the Windows Server 2008 service pack, click the following article number to go to the article in the Microsoft Knowledge Base: 
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies to" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Cryptsvc.dll6.0.6002.22817132,09615-Mar-201214:44x86
For all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Cryptsvc.dll6.0.6002.22817171,00815-Mar-201215:42x64
Cryptsvc.dll6.0.6002.22817132,09615-Mar-201214:44x86
For all supported IA–64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Cryptsvc.dll6.0.6002.22817346,11215-Mar-201216:07IA-64
Cryptsvc.dll6.0.6002.22817132,09615-Mar-201214:44x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about Volume Shadow Copy Service (VSS), go to the following Microsoft website:

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size3,078
Date (UTC)15-Mar-2012
Time (UTC)17:29
PlatformNot Applicable
File nameX86_413ef6b161e440eefffb0bae88ecda02_31bf3856ad364e35_6.0.6002.22817_none_5879794d17e7f6d6.manifest
File versionNot Applicable
File size700
Date (UTC)15-Mar-2012
Time (UTC)17:29
PlatformNot Applicable
File nameX86_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22817_none_786bed2db114f3af.manifest
File versionNot Applicable
File size7,489
Date (UTC)15-Mar-2012
Time (UTC)15:03
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and Windows Server 2008
File nameAmd64_083c1d183390809a9b225a896b8d0869_31bf3856ad364e35_6.0.6002.22817_none_0d85cdca26b20f09.manifest
File versionNot Applicable
File size1,048
Date (UTC)15-Mar-2012
Time (UTC)17:29
PlatformNot Applicable
File nameAmd64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22817_none_d48a88b1697264e5.manifest
File versionNot Applicable
File size7,523
Date (UTC)15-Mar-2012
Time (UTC)16:32
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,102
Date (UTC)15-Mar-2012
Time (UTC)17:29
PlatformNot Applicable
File nameX86_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22817_none_786bed2db114f3af.manifest
File versionNot Applicable
File size7,489
Date (UTC)15-Mar-2012
Time (UTC)15:03
PlatformNot Applicable
Additional files for all supported IA–64-based versions of Windows Server 2008
File nameIa64_89fcf8eda4464b404dcf07917992d027_31bf3856ad364e35_6.0.6002.22817_none_0b09779fdf7b3b17.manifest
File versionNot Applicable
File size1,046
Date (UTC)15-Mar-2012
Time (UTC)17:29
PlatformNot Applicable
File nameIa64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22817_none_786d9123b112fcab.manifest
File versionNot Applicable
File size7,506
Date (UTC)15-Mar-2012
Time (UTC)16:18
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,255
Date (UTC)15-Mar-2012
Time (UTC)17:29
PlatformNot Applicable
File nameX86_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22817_none_786bed2db114f3af.manifest
File versionNot Applicable
File size7,489
Date (UTC)15-Mar-2012
Time (UTC)15:03
PlatformNot Applicable

↑ Back to the top


Keywords: kb, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, kbautohotfix

↑ Back to the top

Article Info
Article ID : 2647841
Revision : 2
Created on : 9/19/2018
Published on : 9/19/2018
Exists online : False
Views : 251