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The Channel service stops when a user signs in to a Group Chat client in Office Communications Server 2007 R2 Group Chat


Symptoms

Consider the following scenario:
  • You set up a Group Chat server pool that contains several Group Chat servers in a Microsoft Office Communications Server 2007 R2 environment.
  • You configure the log level for the Channel service to Debug or Trace.
  • A user signs in to a Group Chat client.
In this scenario, the Channel service on the last started Group Chat Server in the Group Chat server pool stops.

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Cause

This issue occurs because an object reference in a Group Chat function is set to a NULL when the function tries to determine whether the client is local or remote. This causes the Channel service to exit when the logging is set to a DEBUG level or a higher level.

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Resolution

To resolve this issue, install the following cumulative update:
2647090 Description of the cumulative update for Office Communications Server 2007 R2 Group Chat server: January, 2012


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Workaround

To work around this issue, set the log level of the Channel service to INFO level on all Group Chat servers in the pool.

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More Information

For more information about how to set log levels for the Channel service, Lookup service, or Web service, visit the following Microsoft website:

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Keywords: kbqfe, kbsurveynew, kbfix, kbexpertiseinter, kb

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Article Info
Article ID : 2647095
Revision : 1
Created on : 1/7/2017
Published on : 1/19/2012
Exists online : False
Views : 68