Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Error message when you check the connection to the data source in the Data Access Tool: "Unable to load 'msdrda.dll': The specified procedure could not be found"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running a 32-bit version of Windows XP.
  • You installed one of the following:
    • Microsoft OLE DB Provider for DB2 3.0 is installed, and an update is applied that includes the Msdrda.dll file. This file has a file version of 8.0.4302.0 or a later version.
    • Or, the data providers are installed in Host Integration Server 2010 Cumulative Update 1 (CU1).
In this scenario, when you create or edit a Universal Data Link (UDL) and check the connection to the data source in the Data Access Tool (DAT), you may receive an error message as follows:
  • When you click Connect, you receive the following error message:
    Unhandled exception has occurred in your application.

    Unable to load 'msdrda.dll': The specified procedure could not be found. (Exception from HRESULT: 0x8007007F).
  • When you click Sample Query or Packages, you receive the following error message:
    Entry Point Not Found

    The procedure entry point RegGetValueA could not be located in the dynamic link library ADVAPI32.DLL

↑ Back to the top


Cause

This issue occurs because a previous update to the OLE DB Provider for DB2 added a call to the RegGetValue API. The RegGetValue API is not supported in 32-bit versions of Windows XP. The errors that are described in the "Symptoms" section occur when the OLE DB Provider for DB2 calls the unsupported API.

↑ Back to the top


Resolution

Hotfix information

Microsoft OLE DB Provider for DB2 3.0

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For Microsoft OLE DB Provider for DB2 3.0, 32-bit
File nameFile versionFile sizeDateTimePlatform
Db2oledb.dll8.0.4318.2632,65613-Dec-201123:14x86
Ddmstr.dll8.0.4318.267,40813-Dec-201123:14x86
Microsoft.hostintegration.dataaccesslibrary.dll8.0.4318.2788,37613-Dec-201123:14x86
Msdrda.dll8.0.4318.2902,99213-Dec-201123:14x86
For Microsoft OLE DB Provider for DB2 3.0, 64-bit
File nameFile versionFile sizeDateTimePlatform
Db2oledb.dll8.0.4318.2632,65613-Dec-201123:14x86
Ddmstr.dll8.0.4318.267,40813-Dec-201123:14x86
Microsoft.hostintegration.dataaccesslibrary.dll8.0.4318.2788,37613-Dec-201123:14x86
Msdrda.dll8.0.4318.2902,99213-Dec-201123:14x86
Db2oledb.dll8.0.4318.2883,02413-Dec-201123:19x64
Ddmstr.dll8.0.4318.255,12013-Dec-201123:19x64
Microsoft.hostintegration.dataaccesslibrary.dll8.0.4318.2788,37613-Dec-201123:19x86
Msdrda.dll8.0.4318.21,553,23213-Dec-201123:19x64
For Microsoft OLE DB Provider for DB2 3.0, IA-64
File nameFile versionFile sizeDateTimePlatform
Db2oledb.dll8.0.4318.2632,65613-Dec-201123:14x86
Ddmstr.dll8.0.4318.267,40813-Dec-201123:14x86
Microsoft.hostintegration.dataaccesslibrary.dll8.0.4318.2788,37613-Dec-201123:14x86
Msdrda.dll8.0.4318.2902,99213-Dec-201123:14x86
Db2oledb.dll8.0.4318.21,724,75213-Dec-201123:25IA-64
Ddmstr.dll8.0.4318.260,75213-Dec-201123:25IA-64
Microsoft.hostintegration.dataaccesslibrary.dll8.0.4318.2788,37613-Dec-201123:25x86
Msdrda.dll8.0.4318.22,439,50413-Dec-201123:25IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

↑ Back to the top

Article Info
Article ID : 2646715
Revision : 1
Created on : 1/7/2017
Published on : 2/8/2012
Exists online : False
Views : 243