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"The system cannot find the file specified" error message when you print a document on a Windows Server 2008 R2-based terminal server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You establish a Remote Desktop Services session to a Windows Server 2008 R2-based terminal server that has Windows Internet Explorer 9 installed.
  • You do not redirect a printer to the Remote Desktop Services session.
  • You run an application that hosts Internet Explorer 9 and that is compiled with the /TSAWARE:NO option on the terminal server.
  • You try to print a document to a network printer by using this application.
In this scenario, the printer does not print the document. Additionally, you receive an error message that resembles the following:
The system cannot find the file specified.

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Cause

This issue occurs because the FOLDERID_FONTS value points to an incorrect directory. The value should point to the following directory:
C:\Windows\Fonts
However, the value points to the following directory instead:
C:\Users\%username%\Windows\Fonts

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the Remote Desktop Services role installed. For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.1.7601.1775914,172,67211-Jan-201206:41x64
Shell32.dll6.1.7601.2189514,173,18411-Jan-201206:23x64
Shell32.dll6.1.7601.1775912,872,70411-Jan-201205:36x86
Shell32.dll6.1.7601.2189512,873,72811-Jan-201206:04x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about a similar issue that occurs in Windows Server 2008, click the following article number to view the article in the Microsoft Knowledge Base:
2656827 "The system cannot find the file specified" error message when you print a document on a Windows Server 2008-based terminal server
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_604eacfeaf815fce66d2f089d173d33f_31bf3856ad364e35_6.1.7601.17759_none_7789b837361b2a42.manifest
File versionNot applicable
File size1,040
Date (UTC)11-Jan-2012
Time (UTC)14:45
File nameAmd64_ab8dc25a363b1ace1159868aba210da3_31bf3856ad364e35_6.1.7601.21895_none_67b5c1b6b540c40c.manifest
File versionNot applicable
File size699
Date (UTC)11-Jan-2012
Time (UTC)14:45
File nameAmd64_afe7f83274e1c9d14da0867e0b629393_31bf3856ad364e35_6.1.7601.21895_none_1930ab572f31c4fa.manifest
File versionNot applicable
File size1,040
Date (UTC)11-Jan-2012
Time (UTC)14:45
File nameAmd64_ced1f2e2aaa24a1096768330c37cd537_31bf3856ad364e35_6.1.7601.17759_none_c5973525cdab3d63.manifest
File versionNot applicable
File size699
Date (UTC)11-Jan-2012
Time (UTC)14:45
File nameAmd64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.17759_none_ca28f5db28b760c5.manifest
File versionNot applicable
File size1,058,443
Date (UTC)11-Jan-2012
Time (UTC)07:25
File nameAmd64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.21895_none_ca8351ce41f90af7.manifest
File versionNot applicable
File size1,058,443
Date (UTC)11-Jan-2012
Time (UTC)07:23
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.17759_none_d47da02d5d1822c0.manifest
File versionNot applicable
File size1,054,916
Date (UTC)11-Jan-2012
Time (UTC)05:59
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.1.7601.21895_none_d4d7fc207659ccf2.manifest
File versionNot applicable
File size1,054,916
Date (UTC)11-Jan-2012
Time (UTC)06:26

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Keywords: KB2646168, kbsurveynew, kbexpertiseadvanced, kbfix, kbHotfixServer, kbqfe, kbautohotfix

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Article Info
Article ID : 2646168
Revision : 1
Created on : 2/16/2012
Published on : 2/16/2012
Exists online : False
Views : 304