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Error message when you try to move a user's mailbox to another server in Exchange 2000 Server or Exchange Server 2003: "Error: Connecting to destination server"


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Symptoms

When you use the Active Directory Users and Computers snap-in to move an Exchange 2000 user or an Exchange 2003 user from one server to another, the Exchange Task Wizard may report the following error message:
Error: Connecting to destination server. cn=newuser,,CN=Users,DC=regency,DC=com The attempt to log on to the Microsoft Exchange Server computer has failed. The MAPI provider failed. Microsoft Exchange Server Information Store ID no: 8004011d-0512-00000000
Additionally, the following events may be logged in the Application log:

Event Type: Error
Event Source: MSExchangeAdmin
Event Category: MAPI Session
Event ID: 9175
Date: 5/31/2000
Time: 4:53:05 PM
User: N/A
Computer: ServerA
Description: The MAPI call 'OpenMsgStore' failed with the following error:
The attempt to log on to the Microsoft Exchange Server computer has failed. The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000

Event Type: Error
Event Source: MSExchangeAdmin
Event Category: Move Mailbox
Event ID: 9167
Date: 5/31/2000
Time: 4:53:05 PM
User: N/A
Computer: ServerA
Description: Unable to get an administrative interface to the mailbox store on server 'ServerA'.
Error: The attempt to log on to the Microsoft Exchange Server computer has failed. The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000

Event Type: Error
Event Source: MSExchangeAdmin
Event Category: Move Mailbox
Event ID: 1008
Date: 5/31/2000
Time: 4:53:05 PM
User: N/A
Computer: ServerA
Description: Unable to move mailbox 'newuser'.
Error: The attempt to log on to the Microsoft Exchange Server computer has failed. The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000

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Cause

These problems occur because the Move Mailbox task cannot log on to the System Attendant mailbox. The System Attendant user has a mailbox on each server, usually on the default mailbox store. The errors can occur if one or more of the following conditions are true:
  • The default mailbox store on the target server is not mounted.
  • The value for the homeMDB attribute in Active Directory is missing for the System Attendant mailbox on the target server.

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Resolution

To resolve this problem, use the following methods in the order in which they are presented.

Method 1

Make sure that the default mailbox store is mounted. If this does not resolve the problem, go to Method 2.

Method 2

To resolve this problem, populate the value for the homeMDB attribute in Active Directory for the System Attendant mailbox. To do this, follow these steps.
Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

Step 1: Connect to the Active Directory by using ADSI Edit

  1. On a server that has the Windows Support Tools installed, open a command prompt.
  2. Move to the Drive_Letter:\Program Files\Support Tools folder.
  3. Type adsiedit.msc and then press ENTER.
  4. On the Action menu, click Connect to.
  5. In the Connection Settings dialog box, in the Name box, type the name that you want to use for this connection.
  6. In the Connection Point area, click Select a well known Naming Context, and then click Domain in the list.
  7. In the Computer area, click Select or type a domain or Server, type the FQDN of the server in the box, and then click OK.

    Note Do not exit ADSI Edit. Go to step 2.

Step 2: Determine the homeMDB attribute value

  1. In ADSI Edit, expand Domain [Server_Name.Domain_Name.Root_Domain].
  2. Expand DC=Domain_Name,DC=Root_Domain, and then expand CN=Users.
  3. Right-click a suitable user object, and then click Properties. For example, right-click CN=User1, and then click Properties.
  4. In the Attributes list, click homeMDB, and then click Edit.
  5. Note the entry in the Value box so that you can use it in the next section. The entry will resemble the following entry:
    CN=Mailbox Store (Server_Name),CN=First Storage Group,CN=InformationStore,CN=Server_Name,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=Organization_Name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_Name,DC=Root_Domain

Step 3: Enter the homeMDB attribute value for the System Attendant mailbox

  1. In ADSI Edit, expand Configuration [Server_Name.Domain_Name.Root_Domain].
  2. Expand CN=Services, expand CN=Microsoft Exchange, expand CN=Organization_Name, and then expand CN=Administrative Groups.
  3. Expand CN=First_Administrative_Group, expand CN=Servers, and then expand CN=Target_Server_Name. Right-click CN=Microsoft System Attendant, and then click Properties.
  4. In the Attributes list, click homeMDB, and then click Edit.
  5. In the Value box, type the text that you noted in step 5 of the "Step 2: Determine the homeMDB attribute value" section, and then click OK two times.
  6. On the File menu, click Exit.

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Keywords: KB264413, kbprb, kberrmsg

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Article Info
Article ID : 264413
Revision : 3
Created on : 3/31/2008
Published on : 3/31/2008
Exists online : False
Views : 401