Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The RPC Client Access service may crash when you import a .pst file by using the New-MailboxImportRequest cmdlet in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

When you import an Outlook data file (.pst) by using the New-MailboxImportRequest cmdlet in a Microsoft Exchange Server 2010 environment, the Microsoft Exchange RPC Client Access service may crash. Additionally, the following events are logged on the Exchange Server 2010 Client Access server:
Log Name:      Application
Source:        MSExchange Common
Event ID:      4999
Task Category: General
Level:         Error
Keywords:      Classic
Description:Watson report about to be sent for process id: Process ID, with parameters: E12, Build Type, Version Number, M.E.RpcClientAccess.Service, M.Exchange.StoreProvider, M.M.NamedProp..ctor, M.Mapi.MapiExceptionArgument, XXX, Version Number. ErrorReportingEnabled: False

Log Name:      System
Source:        Service Control Manager
Date:          Date
Event ID:      7031
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Computer
Description:The Microsoft Exchange RPC Client Access service terminated unexpectedly.  It has done this Number time(s).  The following corrective action will be taken in Number milliseconds: Restart the service.


↑ Back to the top


Cause

This issue occurs because an Internet Header name contains non-ASCII characters exception occurs. The RPC Client Access service tries to create name properties for each item in the message header of each message in the .pst file. However, the message header name includes non-ASCII characters. Therefore, the RPC Client Access service handler throws an exception causing the RPC Client Access service to crash.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2645995 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 2

↑ Back to the top


Workaround

To work around this issue, you can manually import the .pst file by using the Outlook.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the New-MailboxImportRequest cmdlet, visit the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2642189
Revision : 1
Created on : 1/7/2017
Published on : 2/13/2012
Exists online : False
Views : 303