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The msDS-HasInstantiatedNCs and msDS-hasMasterNCs attributes do not replicate if an authoritative restore is performed in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A domain controller is running Windows Server 2008 R2 in an Active Directory domain environment.
  • You perform an authoritative restore of a Non-Domain Naming Context (NDNC) on the domain controller.

    Note The NDNC does not have a parent NDNC.
  • You perform a full Active Directory replication on the domain controller.
In this scenario, the full Active Directory replication is not completed successfully. The msDS-HasInstantiatedNCs and msDS-hasMasterNCs attributes of the NTDS Site object settings are not replicated. Additionally, events that resemble the following are logged in the Directory Service event log on the domain controller.

Event 1

Source: Microsoft-Windows-ActiveDirectory_DomainService
Date: datetime
Event ID: 1699
Task Category: Replication
Level: Error
Keywords: Classic
User: user name
Computer: computer name
Description:
This directory service failed to retrieve the changes requested for the following directory partition. As a result, it was unable to send change requests to the directory service at the following network address.
Directory partition:
DC=name,DC=name,DC=com
Network address:
address
Extended request code:
0

Additional Data
Error value: 8420 The naming context could not be found.

Event 2

Source: Microsoft-Windows-ActiveDirectory_DomainService
Date: datetime
Event ID: 2914
Task Category: Replication
Level: Warning
Keywords: Classic
User: ANONYMOUS LOGON
Computer: computer name
Description:
The destination Active Directory Domain Controller logging this event processed a link value update on the source object below. The link value refers to a target object that is in the recycled state on the destination Active Directory Domain Controller.

This event indicates that corrective steps failed to replicate the target object in the desired order from the source Active Directory Domain Controller to this destination Active Directory Domain Controller. Updated binaries on the source Active Directory Domain Controller will resolve this condition for future occurrences.

If the target object has not been recently authoritatively restored on the source Active Directory Domain Controller, you can ignore this event.

If the target object was recently authoritatively restored on the source Active Directory Domain Controller, then the link value will exist on the source Active Directory Domain Controller but not on the destination Active Directory Domain Controller and its transitive replication partners in the forest until an administrator takes corrective steps.

Source Object DN:
DN
Source Object GUID:
GUID
Attribute:
msDS-HasInstantiatedNCs/msDS-hasMasterNCs
Target Object DN:
DN
Target Object GUID:
GUID

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Cause

The issue occurs because after an authoritative restore is performed, Active Directory Domain Services (AD DS) does not correctly handle the msDS-HasInstantiatedNCs and msDS-hasMasterNCs attributes of an NDNC during the full Active Directory replication.

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Resolution

Note�This hotfix is preventive and does not resolve this issue after it has occurred. After you install this hotfix, delete the NDNC that was unsuccessfully replicated, and then perform an authoritative restore of the NDNC on every domain controller. To prevent the issue from reoccurring, install the hotfix on all Windows Server 2008 R2-based domain controllers.�

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the AD DS server role installed.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntdsai.dll6.1.7600.210852,725,37605-Nov-201105:30x64
Ntdsai.dll6.1.7601.218552,725,37605-Nov-201105:35x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about a similar issue that occurs in Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
948925 Event IDs 1173 and 1925 are logged after you perform an authoritative restore on a Windows Server 2003-based domain controller to restore an application partition that was previously deleted
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_3278dbc19965bdfce20518d1ff2d6c45_31bf3856ad364e35_6.1.7600.21085_none_8c4ab399a37c90bb.manifest
File versionNot Applicable
File size716
Date (UTC)05-Nov-2011
Time (UTC)13:02
PlatformNot Applicable
File nameAmd64_f043f3f89982410814e9344a5eb07edf_31bf3856ad364e35_6.1.7601.21855_none_a74a879a33940a49.manifest
File versionNot Applicable
File size716
Date (UTC)05-Nov-2011
Time (UTC)13:02
PlatformNot Applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7600.21085_none_4d44b1feebf19015.manifest
File versionNot Applicable
File size3,531
Date (UTC)05-Nov-2011
Time (UTC)06:02
PlatformNot Applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7601.21855_none_4f4ba88ce8ff7213.manifest
File versionNot Applicable
File size3,531
Date (UTC)05-Nov-2011
Time (UTC)06:15
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,741
Date (UTC)05-Nov-2011
Time (UTC)13:02
PlatformNot Applicable

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Keywords: KB2641962, kbexpertiseinter, kbsurveynew, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 2641962
Revision : 1
Created on : 12/14/2011
Published on : 12/14/2011
Exists online : False
Views : 757