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Windows Explorer crashes randomly in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you open Windows Explorer on a computer that is running Windows 7 or Windows Server 2008 R2 in a network environment. In this situation, Windows Explorer crashes randomly.

Note This issue occurs if Network Discovery is enabled on the computer.

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Cause

This issue occurs because the Fdwnet.dll module is incorrectly unloaded.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Fdwnet.dll6.1.7600.2108424,57604-Nov-201104:36x86
Fdwnet.dll6.1.7601.2185424,57604-Nov-201106:17x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Fdwnet.dll6.1.7600.2108428,16004-Nov-201105:30x64
Fdwnet.dll6.1.7601.2185428,16004-Nov-201106:44x64
Fdwnet.dll6.1.7600.2108424,57604-Nov-201104:36x86
Fdwnet.dll6.1.7601.2185424,57604-Nov-201106:17x86

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Workaround

To work around this issue, hide the Network tree in the Windows Explorer navigation pane. To do this, create the following registry entry:
Location: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum
Entry name: F02C1A0D-BE21-4350-88B0-7367FC96EF3C
Type: REG_DWORD
Value: 1

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_38334155e9ecac90f332b310ad0bb345_31bf3856ad364e35_6.1.7600.21084_none_02c68fa35b706bd4.manifest
File versionNot Applicable
File size676
Date (UTC)04-Nov-2011
Time (UTC)13:07
File nameX86_f2aa404ca94606c652eb9ba2686eec82_31bf3856ad364e35_6.1.7601.21854_none_1a41e04fc10f7387.manifest
File versionNot Applicable
File size676
Date (UTC)04-Nov-2011
Time (UTC)13:07
File nameX86_fdwnet_31bf3856ad364e35_6.1.7600.21084_none_3b878169ee83fbcc.manifest
File versionNot Applicable
File size4,873
Date (UTC)04-Nov-2011
Time (UTC)05:46
File nameX86_fdwnet_31bf3856ad364e35_6.1.7601.21854_none_3d8e77f7eb91ddca.manifest
File versionNot Applicable
File size4,873
Date (UTC)04-Nov-2011
Time (UTC)08:10
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_09a8c48b11e95f4ed26efc64e430c8ca_31bf3856ad364e35_6.1.7601.21854_none_c07473509d5f48fe.manifest
File versionNot Applicable
File size1,000
Date (UTC)04-Nov-2011
Time (UTC)13:07
File nameAmd64_19ed8c1680901ef1020896ed9d73bcf7_31bf3856ad364e35_6.1.7600.21084_none_13edad0cadd0ffb8.manifest
File versionNot Applicable
File size1,000
Date (UTC)04-Nov-2011
Time (UTC)13:07
File nameAmd64_fdwnet_31bf3856ad364e35_6.1.7600.21084_none_97a61ceda6e16d02.manifest
File versionNot Applicable
File size4,875
Date (UTC)04-Nov-2011
Time (UTC)06:30
File nameAmd64_fdwnet_31bf3856ad364e35_6.1.7601.21854_none_99ad137ba3ef4f00.manifest
File versionNot Applicable
File size4,875
Date (UTC)04-Nov-2011
Time (UTC)09:13
File nameX86_fdwnet_31bf3856ad364e35_6.1.7600.21084_none_3b878169ee83fbcc.manifest
File versionNot Applicable
File size4,873
Date (UTC)04-Nov-2011
Time (UTC)05:46
File nameX86_fdwnet_31bf3856ad364e35_6.1.7601.21854_none_3d8e77f7eb91ddca.manifest
File versionNot Applicable
File size4,873
Date (UTC)04-Nov-2011
Time (UTC)08:10

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2638018
Revision : 1
Created on : 1/7/2017
Published on : 12/14/2011
Exists online : False
Views : 205