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There are no extended characters when you use an MS-DOS-based program in a Terminal Services session


View products that this article applies to.

Symptoms

On some keyboards, you must press the ALT key that is on the right side of your keyboard to generate many extended characters such as the at sign (@) or the backslash (\). For example, when you use a German keyboard, press and hold the ALT key that is on the right side of your keyboard and then press the Q key to type an at sign.

When you use an MS-DOS-based program in a Terminal Services session, any key that uses the ALT key that is on the right side of your keyboard as a qualifier does not generate any characters. However, when you use the same MS-DOS-based program locally, the program works.

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Cause

When you work locally, the ALT key that is on the right side of your keyboard sends as a single keystroke from the ALT key that is on the right side of your keyboard to the program. When you run the same program in a Terminal Services session, the ALT key that is on the right side of your keyboard is translated into the CTRL+ALT key combination.

This key combination is not handled correctly by the Windows NT Virtual DOS Machine (NTVDM), which provides keyboard input to MS-DOS-based programs.

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Workaround

Microsoft Windows Server 2003

It is easy to work around this problem in Windows Server 2003. Therefore, there is no hotfix available. To work around this problem, follow these steps:
  1. Install US Keyboard layout in addition to your local keyboard. To do this, follow these steps:
    1. In Control Panel, click Regional and Language Options.
    2. On the Languages tab, under Text services and input languages, click Details.
    3. Under Installed services, click Add.
    4. Click to select the Keyboard layout/IME check box, in the Keyboard layout/IME box, click US, and then click OK.
  2. Configure your RDP connection so that Windows shortcut keys always apply to the desktop of the remote computer. To do this, follow these steps:
    1. Click Start, point to All Programs, point to Accessories, point to Communications, and then click Remote Desktop Connection.
    2. On the General tab, click Open, and locate the .rdp file for your connection if you want to open a saved connection.
    3. On the Local Resources tab, under Keyboard, click On the Remote Computer.
    4. On the General tab, click Save As, and save the connection settings.

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Resolution

Microsoft Windows 2000

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
The English-language version of this fix should have the following file attributes or later:
   Date        Time     Version        Size       File name
   ---------------------------------------------------------
   03/22/2000  09:26pm  5.0.2195.1333    221,968  Gdi32.dll
   05/31/2000  03:45pm  5.0.2195.2096    379,152  User32.dll
   06/21/2000  06:54pm  5.0.2195.2096  1,639,568  Win32k.sys
   06/22/2000  05:27pm  5.0.2195.2096    242,960  Winsrv.dll
				

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 2.

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More information

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

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Keywords: KB263749, kbwin2000presp2fix, kbhardware, kbfix, kbbug

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Article Info
Article ID : 263749
Revision : 7
Created on : 2/20/2007
Published on : 2/20/2007
Exists online : False
Views : 465