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CSV LUNs fail if you use a VSS hardware provider to back up virtual machines on a Windows Server 2008 R2-based cluster


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a failover cluster that consists of servers that are running Windows Server 2008 R2.
  • You create a cluster shared volume (CSV) that includes some virtual machines that are owned by different cluster nodes.
  • You back up the virtual machines by using a Volume Shadow Copy Service (VSS) hardware provider. For example, you back up a protection group in Microsoft System Center Data Protection Manager (DPM) 2010.
  • The owner of the CSV changes during the backup process.
In this scenario, the CSV logical unit numbers (LUNs) enter a failed state, and do not come online on the next cluster node. Therefore, the backup process fails.

Notes
  • This issue does not occur if you do not use a VSS hardware provider to back up the virtual machines.
  • This issue does not occur if the change of owner of the CSV is not triggered during the backup process.

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Cause

This issue occurs because the Cluster service incorrectly accesses stale information to determine whether a CSV LUN is in the correct state to start the backup process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.1.7600.211261,277,95213-Jan-201207:54x64
Clusres.dll6.1.7601.218971,280,51213-Jan-201208:08x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.1.7600.211262,118,65613-Jan-201206:47IA-64
Clusres.dll6.1.7601.218972,122,24013-Jan-201206:50IA-64

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Workaround

To work around this issue, back up the virtual machines that are owned by the same cluster node during the backup process.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_049c2988b310090a28154b882ff865f8_31bf3856ad364e35_6.1.7600.21126_none_c454b258b1592b83.manifest
File versionNot Applicable
File size715
Date (UTC)13-Jan-2012
Time (UTC)13:13
PlatformNot Applicable
File nameAmd64_19356bb58f2c429ce7213eaefb526fce_31bf3856ad364e35_6.1.7601.21897_none_57b89844a186572d.manifest
File versionNot Applicable
File size715
Date (UTC)13-Jan-2012
Time (UTC)13:13
PlatformNot Applicable
File nameAmd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7600.21126_none_1d9af0f5cf988356.manifest
File versionNot Applicable
File size2,693
Date (UTC)13-Jan-2012
Time (UTC)08:34
PlatformNot Applicable
File nameAmd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7601.21897_none_1f36c6afccf698ee.manifest
File versionNot Applicable
File size2,693
Date (UTC)13-Jan-2012
Time (UTC)08:57
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_13c86d0bed3a0347518097656d3f2f33_31bf3856ad364e35_6.1.7601.21897_none_ea8e99ae31de22c5.manifest
File versionNot Applicable
File size713
Date (UTC)13-Jan-2012
Time (UTC)13:13
PlatformNot Applicable
File nameIa64_e0e9f580c8306969ac35be828623b58b_31bf3856ad364e35_6.1.7600.21126_none_935be5438e9bc602.manifest
File versionNot Applicable
File size713
Date (UTC)13-Jan-2012
Time (UTC)13:13
PlatformNot Applicable
File nameIa64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7600.21126_none_c17df96817391b1c.manifest
File versionNot Applicable
File size2,691
Date (UTC)13-Jan-2012
Time (UTC)08:25
PlatformNot Applicable
File nameIa64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.1.7601.21897_none_c319cf22149730b4.manifest
File versionNot Applicable
File size2,691
Date (UTC)13-Jan-2012
Time (UTC)08:36
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2637197
Revision : 1
Created on : 3/21/2017
Published on : 2/16/2012
Exists online : False
Views : 171