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An update to improve the restore operation performance of Printbrm.exe in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create lots of print queues on a computer that is running Windows 7 or Windows Server 2008 R2. For example, you create over 500 print queues.
  • You use the Printbrm.exe command-line tool to back up the print queues on the computer.
  • You use Printbrm.exe to try to restore the backup.
In this scenario, it takes Printbrm.exe a long time to finish the restore operation.

Note The Printer Migration Wizard (PrintMig.exe) finishes the restore operation in one-half to one-third of the time when you restore the same number of print queues in Windows Server 2003.

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Cause

This issue occurs because Printbrm.exe uses single-threaded processing when it performs print queue restore operations.

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Resolution

To resolve this issue, install this hotfix on the affected Windows 7 or Windows Server 2008 R2-based computer. After you install this hotfix, Printbrm.exe uses multiple threads to perform print queue restore operations. This change can improve performance between 10 and 50 percent, depending on the environment. The amount of performance improvement also depends on the printer driver that is used and how much random access memory (RAM) is available.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Before you install this hotfix on a computer that is running Windows Server 2008 R2 or Windows Server 2008 R2 SP1, the Print and Document Services role must be installed on the computer.

To install the Print and Document Services role, follow these steps:
  1. Click Start, point to Administrative Tools, and then click Server Manager.
  2. In the navigation pane of Server Manager, right-click Roles, and then click Add Roles.
  3. In the Add Roles Wizard, on the Select Server Roles page, select the Print and Document Services check box.
  4. On the Add Role Services page, select the Print Server check box.
    Note This installs the Print Server role service and Print Management snap-in, and configures the server to be a print server.
For more information about how to install the Print and Document Services role, visit the following Microsoft website:

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    16xxx
    Windows 7 and Windows Server 2008 R2RTMGDR
    6.1.760
    0.
    21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Printbrm.exe6.1.7600.2107920,48029-Oct-201104:31x86
Printbrmengine.exe6.1.7600.21079221,18429-Oct-201104:31x86
Printbrmps.dll6.1.7600.1638513,31214-Jul-200901:16x86
Printbrmui.exe1.0.0.066,04829-Oct-201104:31x86
Printbrm.exe6.1.7601.1751420,48020-Nov-201012:17x86
Printbrmengine.exe6.1.7601.21849221,18429-Oct-201106:14x86
Printbrmps.dll6.1.7600.1638513,31214-Jul-200901:16x86
Printbrmui.exe1.0.0.066,04820-Nov-201012:17x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Printbrm.exe6.1.7600.1638521,50414-Jul-200901:39x64
Printbrmengine.exe6.1.7600.21079268,28829-Oct-201105:30x64
Printbrmps.dll6.1.7600.1638519,45614-Jul-200901:41x64
Printbrmui.exe1.0.0.071,68014-Jul-200901:39x64
Printbrm.exe6.1.7600.1638521,50414-Jul-200901:39x64
Printbrmengine.exe6.1.7601.21849268,28829-Oct-201106:38x64
Printbrmps.dll6.1.7600.1638519,45614-Jul-200901:41x64
Printbrmui.exe1.0.0.071,68014-Jul-200901:39x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size2,478
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameX86_91fd4fb67a9c03cd1a6de7cd97bcf4fb_31bf3856ad364e35_6.1.7601.21849_none_330bd96cd68619d4.manifest
File versionNot applicable
File size711
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameX86_b4313039b0b28fe43a77c6a17ff17db0_31bf3856ad364e35_6.1.7600.21079_none_9e5973c2a115cb4e.manifest
File versionNot applicable
File size711
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-tools-printbrm_31bf3856ad364e35_6.1.7600.21079_none_8228ce16bfba3775.manifest
File versionNot applicable
File size76,920
Date (UTC)29-Oct-2011
Time (UTC)14:44
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-tools-printbrm_31bf3856ad364e35_6.1.7601.21849_none_842fc4a4bcc81973.manifest
File versionNot applicable
File size76,920
Date (UTC)29-Oct-2011
Time (UTC)14:44
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_1953afa21efa3b722e4e7277d5644acd_31bf3856ad364e35_6.1.7600.21079_none_a2ba278fc5af3b9d.manifest
File versionNot applicable
File size715
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameAmd64_33580614cceaa3798ee725d57763ab88_31bf3856ad364e35_6.1.7601.21849_none_4f08ba1066601f31.manifest
File versionNot applicable
File size715
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameAmd64_microsoft-windows-p..ting-tools-printbrm_31bf3856ad364e35_6.1.7600.21079_none_de47699a7817a8ab.manifest
File versionNot applicable
File size76,924
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameAmd64_microsoft-windows-p..ting-tools-printbrm_31bf3856ad364e35_6.1.7601.21849_none_e04e602875258aa9.manifest
File versionNot applicable
File size76,924
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,924
Date (UTC)29-Oct-2011
Time (UTC)14:40
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2636591
Revision : 1
Created on : 1/7/2017
Published on : 1/4/2013
Exists online : False
Views : 195